poj2431 优先队列

17 篇文章 0 订阅

 

 

如题:http://poj.org/problem?id=2431

 

Expedition
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7851 Accepted: 2296

Description

A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck's fuel tank. The truck now leaks one unit of fuel every unit of distance it travels.

To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows can stop to acquire additional fuel (1..100 units at each stop).

The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000).

Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all.

Input

* Line 1: A single integer, N

* Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop.

* Line N+2: Two space-separated integers, L and P

Output

* Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.

Sample Input

4
4 4
5 2
11 5
15 10
25 10

Sample Output

2

Hint

INPUT DETAILS:

The truck is 25 units away from the town; the truck has 10 units of fuel. Along the road, there are 4 fuel stops at distances 4, 5, 11, and 15 from the town (so these are initially at distances 21, 20, 14, and 10 from the truck). These fuel stops can supply up to 4, 2, 5, and 10 units of fuel, respectively.

OUTPUT DETAILS:

Drive 10 units, stop to acquire 10 more units of fuel, drive 4 more units, stop to acquire 5 more units of fuel, then drive to the town.

 

 

 

很简单的题,给出个距离L,和油量P,1单位长度消耗1单位油,途中有加油站,给出每个加油站距离终点的距离和可以加的油量,求到达终点最少加几次油。

 

思路:在汽车油量还有的时候一直开,不管加不加油,当油量耗尽时,将路途中的所有加油站依次入优先队列(油量多的优先)(大根堆),然后加一次油,继续开,直到终点。队列为空代表没有可加的油,并且这时的距离小于终点,输出-1,不能到达。

还要注意边界条件,如果一开始P》=L 直接输出0. 不用加油就可以到达,否则会输出1,WA掉。

还要注意的是加油站的距离是距离终点的,要换算成距离起点的来做。

 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#include<vector>
using namespace std;

struct node
{
 int dis;
 int oil;
}add_oil[10005];
int N,L,P;

struct cmp
{
 bool operator ()(node &a,node &b)
 {
  return a.oil<b.oil;
 }
};
int cmp1(node &a,node &b)
{
 return a.dis<b.dis;
}

int main()
{
 //freopen("C:\\Users\\Administrator\\Desktop\\1\\exp.2.in","r",stdin);
 scanf("%d",&N);
 int i;
 for(i=1;i<=N;i++)
  scanf("%d%d",&add_oil[i].dis,&add_oil[i].oil);
 scanf("%d%d",&L,&P);
 if(P>=L)
 {
  printf("0\n");
  return 0;
 }
 for(i=1;i<=N;i++)
  add_oil[i].dis=L-add_oil[i].dis;
 priority_queue<node,vector<node>,cmp>q;
 sort(add_oil+1,add_oil+1+N,cmp1);
 i=1;
 int count=0;
 while(i<=N)
 {
 while(add_oil[i].dis<=P&&i<=N)
  q.push(add_oil[i++]);
 if(!q.empty())
 {
 P+=q.top().oil;
 q.pop();
 count++;
 if(P>=L)
 {
  printf("%d\n",count);
  break;
 }
 }
 else
 {
  printf("-1\n");
  break;
 }
 }
 return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值