poj3259 负权环判定

 

 

如题:http://poj.org/problem?id=3259

Wormholes
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 33015 Accepted: 12016

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

Source

 

 

题目大意:N个顶点,M条双向边,W条虫洞(特殊边,单向,权值为负),问构建这样一个图后图中是否存在负权环。

 

思路:使用bellman_ford()进行负权环判定,对于一个顶点,如果图中不存在负权环,它最多更新V-1次,如果第V次时,有某一个点还被更新,则存在负权环,初始d数组可以设置为0。

 

#include<iostream>
#include<cstdio>
#include<queue>
using namespace std;

struct node
{
 int from,to,time;
 node(){}
 node(int a,int b,int c):from(a),to(b),time(c){}
}edge[2500*2+200+50];
 int F,N,M,W;
  int cnt;

int Bellman_ford()
{
 int d[505]={0};
 int i,j;
 for(i=0;i<N;i++)
  for(j=0;j<cnt;j++)
   if(d[edge[j].to]>d[edge[j].from]+edge[j].time)
   {
    d[edge[j].to]=d[edge[j].from]+edge[j].time;
    if(i==N-1)
     return 1;
   }
 return 0;
}
int main()
{
// freopen("C:\\1.txt","r",stdin);
 cin>>F;
 while(F--)
 {
  memset(edge,0,sizeof(edge));
  int i;
  cin>>N>>M>>W;
  cnt=0;
  for(i=1;i<=M;i++)
  {
   int a,b,c;
   scanf("%d%d%d",&a,&b,&c);
   edge[cnt++]=node(a,b,c);
   edge[cnt++]=node(b,a,c);
  }
  for(i=1;i<=W;i++)
  {
   int a,b,c;
   scanf("%d%d%d",&a,&b,&c);
   edge[cnt++]=node(a,b,-c);
  }
  int res=Bellman_ford();
  if(res)
   printf("YES\n");
  else
   printf("NO\n");
 }

}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值