poj2139

 

如题:http://poj.org/problem?id=2139

Six Degrees of Cowvin Bacon
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3264 Accepted: 1519

Description

The cows have been making movies lately, so they are ready to play a variant of the famous game "Six Degrees of Kevin Bacon".

The game works like this: each cow is considered to be zero degrees of separation (degrees) away from herself. If two distinct cows have been in a movie together, each is considered to be one 'degree' away from the other. If a two cows have never worked together but have both worked with a third cow, they are considered to be two 'degrees' away from each other (counted as: one degree to the cow they've worked with and one more to the other cow). This scales to the general case.

The N (2 <= N <= 300) cows are interested in figuring out which cow has the smallest average degree of separation from all the other cows. excluding herself of course. The cows have made M (1 <= M <= 10000) movies and it is guaranteed that some relationship path exists between every pair of cows.

Input

* Line 1: Two space-separated integers: N and M

* Lines 2..M+1: Each input line contains a set of two or more space-separated integers that describes the cows appearing in a single movie. The first integer is the number of cows participating in the described movie, (e.g., Mi); the subsequent Mi integers tell which cows were.

Output

* Line 1: A single integer that is 100 times the shortest mean degree of separation of any of the cows.

Sample Input

4 2
3 1 2 3
2 3 4

Sample Output

100

Hint

[Cow 3 has worked with all the other cows and thus has degrees of separation: 1, 1, and 1 -- a mean of 1.00 .]

Source

 

题目大意:有N个奶牛演M个电影,给出每部电影参加的奶牛数和参加的奶牛,问所有奶牛中和其他奶牛平均degree最小,规定如果2只奶牛在某一个电影中,他们之间连一条degree=1的边。输出的是最小平均degree*100.

 

思路:使用floyd求出每2只奶牛的最短距离,找到一个到其他奶牛和最小的,也就是平均距离最小,除以(N-1),再*100输出就行了。

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
#define min(a,b)(a<b?a:b)

int map[305][305];
int vex[10005];

int main()
{
// freopen("C:\\1.txt","r",stdin);
 int N,M;
 cin>>N>>M;
 int i,j,k;
   for(i=0;i<305;i++)
  for(j=0;j<305;j++)
   map[i][j]=0x3f3f3f3f;
 for(i=1;i<=M;i++)
 {
  int n;
  scanf("%d",&n);
  for(k=1;k<=n;k++)
   scanf("%d",&vex[k]);
  for(j=1;j<=n;j++)
   for(k=j+1;k<=n;k++)
   {
    map[vex[j]][vex[k]]=1;
    map[vex[k]][vex[j]]=1;
   }
 }

 for(k=1;k<=N;k++)
  for(i=1;i<=N;i++)
   for(j=1;j<=N;j++)
    map[i][j]=min(map[i][j],map[i][k]+map[k][j]);
   int ans=0x3f3f3f3f;
 for(i=1;i<=N;i++)
 {
  k=0;
  for(j=1;j<=N;j++)
   if(i!=j)
   k+=map[i][j];
  ans=min(ans,k);
 }
 cout<<100*ans/(N-1)<<endl;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值