poj2785 折半枚举

27 篇文章 0 订阅

 

 

如题:http://poj.org/problem?id=2785

4 Values whose Sum is 0
Time Limit: 15000MS Memory Limit: 228000K
Total Submissions: 16388 Accepted: 4753
Case Time Limit: 5000MS

Description

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .

Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 2 28 ) that belong respectively to A, B, C and D .

Output

For each input file, your program has to write the number quadruplets whose sum is zero.

Sample Input

6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45

Sample Output

5

Hint

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).

Source

 

 

 

题目很简单。

 

思路:如果分别从ABCD4个集合中取出元素去匹配,复杂度N^4。铁定超时。这里采用枚举CD集合的每一种可能,每一种可能要求+AB分别一个元素的和为0。

那么开一个数组保存AB所有可能的和,然后排序,用二分搜索找到匹配。复杂度O(N^2logN).

 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define MAXN 4005

int A[MAXN];
int B[MAXN];
int C[MAXN];
int D[MAXN];
int AB[MAXN*MAXN];
int N;

int main()
{
// freopen("C:\\1.txt","r",stdin);
 cin>>N;
 int i,j;
 for(i=0;i<N;i++)
  scanf("%d%d%d%d",&A[i],&B[i],&C[i],&D[i]);
 for(i=0;i<N;i++)
  for(j=0;j<N;j++)
   AB[i*N+j]=A[i]+B[j];
 sort(AB,AB+N*N);
 int res=0;
 for(i=0;i<N;i++)
  for(j=0;j<N;j++)
  {
   int ab=-(C[i]+D[j]);
   res+=upper_bound(AB,AB+N*N,ab)-lower_bound(AB,AB+N*N,ab);
  }
 cout<<res<<endl;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值