poj1797 dijsktra变形

 

如题:http://poj.org/problem?id=1797

Heavy Transportation
Time Limit: 3000MS Memory Limit: 30000K
Total Submissions: 21783 Accepted: 5793

Description

Background
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight.
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know.

Problem
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions.

Input

The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.

Sample Input

1
3 3
1 2 3
1 3 4
2 3 5

Sample Output

Scenario #1:
4

Source

TUD Programming Contest 2004, Darmstadt, Germany

 

题意:给出一堆双向边,权值是本条路可运输的最大量。求出最大能运输多重的东西

 

思路:不难发现,一条路径最大运输量取决于这条路径的最小权值边。对dijsktra算法松弛操作进行修改。

dis[i]代表到当前顶点i的这条路径的最大承重值。


  for(j=1;j<=n;j++)
  {
   if(vis[j]) continue;
   dis[j]=MAX(dis[j],MIN(dis[k],a[k][j]));
  }

 松弛操作,理解一下就能懂。

 

 

#include<iostream>
using namespace std;
#define MAXN 1005
int a[MAXN][MAXN];
int dis[MAXN];
bool vis[MAXN];
int MAX(int a,int b)
{return a>b?a:b;}
int MIN(int a,int b)
{return a>b?b:a;}

void dij(int v,int n)
{
 memset(vis,false,sizeof(vis));
 int i,j;
 for(i=1;i<=n;i++)
  dis[i]=a[v][i];
 vis[v]=true;
 for(i=1;i<n;i++)
 {
  int temp=-1,k=v;
  for(j=1;j<=n;j++)
  {
   if(vis[j]) continue;
   if(temp<dis[j])
   {
    temp=dis[j];
    k=j;
   }
  }
  vis[k]=true;
  for(j=1;j<=n;j++)
  {
   if(vis[j]) continue;
   dis[j]=MAX(dis[j],MIN(dis[k],a[k][j]));
  }
 }
}
int main()
{
// freopen("C:\\1.txt","r",stdin);
 int N;
 cin>>N;
 int count=0;
 while(N--)
 {
  count++;
  memset(a,-1,sizeof(a));
  int n,m;
  scanf("%d %d",&n,&m);
  int i;
  for(i=1;i<=m;i++)
  {
   int t1,t2,w;
   scanf("%d %d %d",&t1,&t2,&w);
   a[t1][t2]=w;
   a[t2][t1]=w;
  }
  dij(1,n);
  printf("Scenario #%d:\n%d\n",count,dis[n]);
  printf("\n");
 }
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值