如题:http://poj.org/problem?id=1008
Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 69409 | Accepted: 21362 |
Description
For religious purposes, the Maya used another calendar in which the year was called Tzolkin (holly year). The year was divided into thirteen periods, each 20 days long. Each day was denoted by a pair consisting of a number and the name of the day. They used 20 names: imix, ik, akbal, kan, chicchan, cimi, manik, lamat, muluk, ok, chuen, eb, ben, ix, mem, cib, caban, eznab, canac, ahau and 13 numbers; both in cycles.
Notice that each day has an unambiguous description. For example, at the beginning of the year the days were described as follows:
1 imix, 2 ik, 3 akbal, 4 kan, 5 chicchan, 6 cimi, 7 manik, 8 lamat, 9 muluk, 10 ok, 11 chuen, 12 eb, 13 ben, 1 ix, 2 mem, 3 cib, 4 caban, 5 eznab, 6 canac, 7 ahau, and again in the next period 8 imix, 9 ik, 10 akbal . . .
Years (both Haab and Tzolkin) were denoted by numbers 0, 1, : : : , where the number 0 was the beginning of the world. Thus, the first day was:
Haab: 0. pop 0
Tzolkin: 1 imix 0
Help professor M. A. Ya and write a program for him to convert the dates from the Haab calendar to the Tzolkin calendar.
Input
NumberOfTheDay. Month Year
The first line of the input file contains the number of the input dates in the file. The next n lines contain n dates in the Haab calendar format, each in separate line. The year is smaller then 5000.
Output
Number NameOfTheDay Year
The first line of the output file contains the number of the output dates. In the next n lines, there are dates in the Tzolkin calendar format, in the order corresponding to the input dates.
Sample Input
3 10. zac 0 0. pop 0 10. zac 1995
Sample Output
3 3 chuen 0 1 imix 0 9 cimi 2801
Source
题目大意:maya人有2种日历,365天的 haab和260天的Tzolkin。要求给出一个haab历,转为Tzolkin历日期。
思路:首先计算出给出的haab历一共有多少天sumday,然后Tozlkin历的年数可以算old_y=old_y=sumday/260;天数old_d=sumday%260.要注意的是old_d==0代表的是上一年的最后一天,然后算old_m=old_d%20。同样old_m==0代表是第20个月。old_d%=13. old_d==0 代表的是old_d=13.
然后输出cout<<old_d<<" "<<old_month[old_m]<<" "<<old_y<<endl;
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
char new_month[20][15]={"","pop","no","zip","zotz","tzec","xul","yoxkin",
"mol","chen","yax","zac","ceh","mac","kankin","muan"
,"pax","koyab","cumhu","uayet"};
char old_month[21][15]={"","imix","ik","akbal","kan","chicchan","cimi"
,"manik","lamat","muluk","ok","chuen","eb"
,"ben","ix","mem","cib","caban","eznab",
"canac","ahau"};
int main()
{
// freopen("C:\\1.txt","r",stdin);
int T;
cin>>T;
cout<<T<<endl;
int new_d,new_m,new_y;
int old_y,old_m,old_d;
while(T--)
{
char dot;
char s[15];
cin>>new_d>>dot>>s>>new_y;
int i;
for(i=1;i<=19;i++)
if(strcmp(new_month[i],s)==0)
{
new_m=i;
break;
}
int sumday=new_y*365+(new_m-1)*20+new_d+1;
old_y=sumday/260;
old_d=sumday%260;
if(old_d==0)
{
old_d=260;
old_y--;
}
old_m=old_d%20;
if(old_m==0)
old_m=20;
old_d%=13;
if(old_d==0)
old_d=13;
cout<<old_d<<" "<<old_month[old_m]<<" "<<old_y<<endl;
}
}