POJ 2318 Toys(判断点在直线的方向)

TOYS
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 16656 Accepted: 7994
Description

Calculate the number of toys that land in each bin of a partitioned toy box.
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys.

John’s parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box.

For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.
Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.
Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.
Sample Input

5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0
Sample Output

0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2
Hint

As the example illustrates, toys that fall on the boundary of the box are “in” the box.
Source

Rocky Mountain 2003

题意:有一个矩形箱子,以(x1,y1)(左上)和(x2,y2)(右下)为对角线,里面有n个隔板,不相交,给你M个点,输出n+1个区域里分别有多少点

做法:判断点在这n条线的哪边,二分求出刚好在点顺时针方向的直线,这条直线的标号就是这个点所在的区域号,统计一遍就可以了

关于如何判断:利用叉积
叉积:a×b<0时 a在b的逆时针方向
~ >0时,a在b的顺时针方向
=0时 a,b共线

点在直线的哪一边:
这里写图片描述
如图,规定直线的方向是上到下的,当点在直线的逆时针方向时 aXb>0
在顺时针方向时,aXb<0
在直线上时就=0了

注意二分的形式(对整数二分)

#include <cstdio>
#include <iostream>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <queue>
#include <map>
#include <stack>
#include <vector>
#define maxn 10010
#define maxe 100010
typedef long long ll;
using namespace std;
const double eps=1e-5;
const int inf=0x3f3f3f3f3f;
struct Point
{
    int x,y;
    Point(){};
    Point(int a,int b)
    {
        x=a,y=b;
    }
    void input()
    {
        scanf("%d%d",&x,&y);
    }
    Point operator +(Point a)
    {
        Point b(x+a.x,y+a.y);
        return b;
    }
    Point operator -(Point a)
    {
        Point b(x-a.x,y-a.y);
        return b;
    }
    int operator *(Point a)
    {
        return x*a.x+y*a.y;
    }
    int operator ^(Point a)
    {
        return x*a.y-y*a.x;
    }
    bool operator <(Point a)
    {
        return x<a.x;
    }
};
struct Line
{
    Point a,b;
    Line(){};
    Line(Point x,Point y)
    {
        a=x,b=y;
    }
};
int cal(Point a,Point b,Point c)
{
    return (b-a)^(c-a);
}
//判断点在直线BC的哪一方(顺时针或逆时针)
int ans[maxn];
Line l[maxn];
int n,m;
Point ur,ld;
int main()
{
    int a,b;
    Point c,d;
    Line l1;
    //freopen("in.txt","r",stdin);
    while(scanf("%d",&n)==1)
    {
        if(n==0)break;
        scanf("%d",&m);
        ur.input();
        ld.input();
        memset(ans,0,sizeof(ans));
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&a,&b);
            c=Point(a,ur.y);
            d=Point(b,ld.y);
            l[i]=Line(c,d);
        }
        c=Point(ld.x,ur.y);
        d=Point(ld.x,ld.y);
        l[n]=Line(c,d);
        for(int i=0;i<m;i++)
        {
            c.input();
            int st=0,ed=n,mid,index=n;
            while(st<=ed)
            {
                mid=(st+ed)/2;
                if(cal(c,l[mid].a,l[mid].b)<0)
                {
                    ed=mid-1;
                    index=mid;
                }
                else
                {
                    st=mid+1;
                }
            }
            ans[index]++;
        }
        for(int i=0;i<=n;i++)
        {
            printf("%d: %d\n",i,ans[i]);
        }
        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值