关于邻接矩阵和邻接表

3 篇文章 0 订阅

关于临界矩阵和邻接表的使用情况

在很多图论的题目中,如果题目本身没有明确指出两个顶点只有最多只有一条直达的边的话那么最好使用邻接表来存储所有的边,因为邻接矩阵会用某一条边来覆盖之前的边,这条边可以是最后输入的边,也可以是你设定了相应条件的边,如果这下边的边权不一样,就会很容易出现错误。比如求最短路的时候用之后出现的边覆盖了最短的边,或者是求边的入度出度的时候只记录了一条边以至于出错。

HDU 3342 Legal or Not

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11758    Accepted Submission(s): 5532


Problem Description
ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?

We all know a master can have many prentices and a prentice may have a lot of masters too, it's legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian's master and, at the same time, 3xian is HH's master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not.

Please note that the "master and prentice" relation is transitive. It means that if A is B's master ans B is C's master, then A is C's master.
 

Input
The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y's master and y is x's prentice. The input is terminated by N = 0.
TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.
 

Output
For each test case, print in one line the judgement of the messy relationship.
If it is legal, output "YES", otherwise "NO".
 

Sample Input
  
  
3 2 0 1 1 2 2 2 0 1 1 0 0 0
 

Sample Output
  
  
YES NO

使用邻接矩阵的错误做法:

#include <iostream>
#include <queue>
#include <stdlib.h>
#include <stdio.h>
#include <map>
#include <string>
#include <cstdlib>
#include <stack>
#include <vector>
#include <math.h>
#include <algorithm>
#include <typeinfo>
#include <cstring>


using namespace std;
typedef long long ll;

const ll inf = 1061109567;
const int maxn = 1002;

int n,m;

int mat[maxn][maxn];

int vex_in[maxn];


int TopoSort(){
    queue<int> q;
    int s[maxn]={0};
    int cnt=0;
    for(int i=0;i<n;i++){
        if(vex_in[i]==0)    q.push(i);
    }

    while(!q.empty()){
        int p=q.front();
        q.pop();
        s[p]=1;
        cnt++;
        for(int i=0;i<n;i++){
            if(mat[p][i]){
                vex_in[i]--;
                if(vex_in[i]==0)    q.push(i);
            }
        }
    }
    /*for(int i=0;i<n;i++)
        if(!s[i])    return 0;*/
    if(cnt!=n)    return 0;
    return 1;
}

int main(int argc, char const *argv[])
{
    while(cin>>n>>m&&m&&n){
        for(int i=0;i<n;i++){
            vex_in[i]=0;
            for(int j=0;j<n;j++){
                mat[i][j]=0;
            }
        }

        int a,b;
        for(int i=0;i<m;i++){
            cin>>a>>b;
            mat[a][b]=1;
            vex_in[b]++;
        }
        if(TopoSort())
            cout<<"YES";
        else cout<<"NO";
        cout<<endl;
    }
    return 0;
}

此时莫名奇妙的wa,虽然我没见到测试样例,但是猜测可能是存在上述说的情况。于是改用邻接表a了。


#include <iostream>
#include <queue>
#include <stdlib.h>
#include <stdio.h>
#include <map>
#include <string>
#include <cstdlib>
#include <stack>
#include <vector>
#include <math.h>
#include <algorithm>
#include <typeinfo>
#include <cstring>


using namespace std;
typedef long long ll;

const ll inf = 1061109567;
const int maxn = 1002;

int n,m;

int mat[maxn][maxn];

std::vector<int> edge[maxn];

int vex_in[maxn];


int TopoSort(){
	queue<int> q;
	//int s[maxn]={0};
	int cnt=0;
	for(int i=0;i<n;i++){
		if(vex_in[i]==0)	q.push(i);
	}

	while(!q.empty()){
		int p=q.front();
		q.pop();
		//s[p]=1;
		cnt++;
		int len=edge[p].size();
		for(int i=0;i<len;i++){
			vex_in[edge[p][i]]--;
			if(vex_in[edge[p][i]]==0)	q.push(edge[p][i]);
		}
	}
	/*for(int i=0;i<n;i++)
		if(!s[i])	return 0;*/
	if(cnt!=n)	return 0;
	return 1;
}

int main(int argc, char const *argv[])
{
	while(cin>>n>>m&&m&&n){
		for(int i=0;i<n;i++){
			vex_in[i]=0;
			edge[i].clear();
		}

		int a,b;
		for(int i=0;i<m;i++){
			cin>>a>>b;
			edge[a].push_back(b);
			vex_in[b]++;
		}
		if(TopoSort())
			cout<<"YES";
		else cout<<"NO";
		cout<<endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值