1002 A+B for Polynomials

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K , N 1 ​ ​ , a ​ N ​ 1 ​ ​ ​ ​ , N 2 a ​ N ​ 2 , . . . , ​ ​ ​ ​ N K a ​ N ​ K K, N_1​​, a_{​N​_1}​​​​, N_2a_{​N​_2}, ... , ​​​​N_Ka_{​N​_K} K,N1,aN1,N2aN2,...,NKaNK

where K K K is the number of nonzero terms in the polynomial, N ​ i N​_i Ni​​ and a ​ N i a_{​N_i} aNi​​​​ ( i = 1 , 2 , ⋯ , K ) (i=1,2,⋯,K) (i=1,2,,K) are the exponents and coefficients, respectively. It is given that 1 ≤ K ≤ 10 , 0 ≤ N K ​ ​ &lt; ⋯ &lt; N ​ 2 ​ ​ &lt; N ​ 1 ​ ​ ≤ 1000 1≤K≤10,0≤N_K​​&lt;⋯&lt;N​_2​​&lt;N​_1​​≤1000 1K100NK<<N2<N11000.

Output Specification:

For each test case you should output the sum of A A A and B B B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2


解题思路:

只需维护一个数组,数组下标表示多项式的幂次,数组值表示系数;先读入 A A A的值,之后在读入B时,进行逐个相加,最后输出系数不为 0 的项即可,注意结构体数组初始化时所有系数皆为 0;


#include <iostream>
#include <iomanip>
using namespace std;

int main()
{
	double A[1001] = { 0 };
	int K, exp;
	double coff;
	cin >> K;
	for (int i = 0; i < K; i++) {
		cin >> exp >> coff;
		A[exp] = coff;
	}
	cin >> K;
	for (int i = 0; i < K; i++) {
		cin >> exp >> coff;
		A[exp] += coff;
	}
	int cont = 0;
	for (int i = 0; i < 1001; i++)
		if (A[i] != 0)
			cont++;
	cout << cont;
	for (int i = 1000; i >= 0; i--) {
		if (A[i] != 0) 
			cout << " " << i << " " << fixed << setprecision(1) << A[i];
	}
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值