Uva1594 Ducci序列

Uva1594 Ducci序列


)

A Ducci sequence is a sequence of n-tuples of integers. Given an n-tuple of integers (a1, a2, · · · , an), the next n-tuple in the sequence is formed by taking the absolute differences of neighboring integers:

                                       (a1, a2, · · · , an) → (|a1 − a2|, |a2 − a3|, · · · , |an − a1|)

Ducci sequences either reach a tuple of zeros or fall into a periodic loop. For example, the 4-tuple sequence starting with 8,11,2,7 takes 5 steps to reach the zeros tuple:

                         (8, 11, 2, 7) → (3, 9, 5, 1) → (6, 4, 4, 2) → (2, 0, 2, 4) → (2, 2, 2, 2) → (0, 0, 0, 0).

The 5-tuple sequence starting with 4,2,0,2,0 enters a loop after 2 steps:

(4, 2, 0, 2, 0) → (2, 2, 2, 2, 4) → (0,0,0,2,2) → (0, 0, 2, 0, 2) → (0, 2, 2, 2, 2) → (2, 0, 0, 0, 2) → (2, 0, 0, 2, 0) → (2, 0, 2, 2, 2) → (2, 2, 0, 0, 0) → (0, 2, 0, 0, 2) → (2, 2, 0, 2, 2) → (0, 2, 2, 0, 0) → (2, 0, 2, 0, 0) → (2, 2, 2, 0, 2) → (0, 0, 2, 2, 0) → (0, 2, 0, 2, 0) → (2, 2, 2, 2, 0) → (0,0,0,2,2) → · · ·

Given an n-tuple of integers, write a program to decide if the sequence is reaching to a zeros tuple or a periodic loop.

Input

Your program is to read the input from standard input. The input consists of T test cases. The number of test cases T is given in the first line of the input. Each test case starts with a line containing an integer n (3 ≤ n ≤ 15), which represents the size of a tuple in the Ducci sequences. In the following line, n integers are given which represents the n-tuple of integers. The range of integers are from 0 to 1,000. You may assume that the maximum number of steps of a Ducci sequence reaching zeros tuple or making a loop does not exceed 1,000.

Output

Your program is to write to standard output. Print exactly one line for each test case. Print ‘LOOP’ if the Ducci sequence falls into a periodic loop, print ‘ZERO’ if the Ducci sequence reaches to a zeros tuple.

Sample Input

4

4

8 11 2 7

5

4 2 0 2 0

7 0 0 0 0 0 0 0

6

1 2 3 1 2 3

Sample Output

ZERO

LOOP

ZERO

LOOP
————————————————


#include<iostream>
#include<cstdio>
#include<vector>
#include<algorithm>
#include<sstream>

using namespace std;

vector<int> ducci;
vector<int> Ducci;
int n;
bool is_zero(vector<int> d);
void caculate(int n);
bool is_circle(vector<int> d);


int main()
{

	while (cin >> n)
	{
		int temp;
		for (int i = 0; i < n; i++)
		{
			cin >> temp;
			ducci.push_back(temp);
			Ducci.push_back(temp);
		}

		caculate(1002);
	}
	return 0;
}
void caculate(int times)
{
	times -= 1;
	cout << times << endl;

	if (times == 0) { cout << "loop!" << endl; return; }

	int buf = ducci[0];
	for (int i = 0; i < n-1; i++)
		ducci[i] = abs(ducci[i] - ducci[i + 1]);
	ducci[n - 1] = abs(ducci[n - 1] - buf);

	if (is_zero(ducci)) { cout << "is zero" << endl; return; }
	caculate(times);
}

bool is_zero(vector<int> d)
{
	int count = 0;
	for (int i = 0; i < n; i++)
	{
		if (d[i] == 0) count++;
	}
	if (count == n) return true;
	else return false;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值