hdu 3018 Ant Trip(一笔画问题)

Ant Trip

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1169    Accepted Submission(s): 428


Problem Description
Ant Country consist of N towns.There are M roads connecting the towns.

Ant Tony,together with his friends,wants to go through every part of the country. 

They intend to visit every road , and every road must be visited for exact one time.However,it may be a mission impossible for only one group of people.So they are trying to divide all the people into several groups,and each may start at different town.Now tony wants to know what is the least groups of ants that needs to form to achieve their goal.
 

Input
Input contains multiple cases.Test cases are separated by several blank lines. Each test case starts with two integer N(1<=N<=100000),M(0<=M<=200000),indicating that there are N towns and M roads in Ant Country.Followed by M lines,each line contains two integers a,b,(1<=a,b<=N) indicating that there is a road connecting town a and town b.No two roads will be the same,and there is no road connecting the same town.
 

Output
For each test case ,output the least groups that needs to form to achieve their goal.
 

Sample Input
  
  
3 3 1 2 2 3 1 3 4 2 1 2 3 4
 

Sample Output
  
  
1 2
Hint
New ~~~ Notice: if there are no road connecting one town ,tony may forget about the town. In sample 1,tony and his friends just form one group,they can start at either town 1,2,or 3. In sample 2,tony and his friends must form two group.
 
题意:给出一个无向图,问最少画多少笔可以遍历图中所有边恰好一次。
思路:一笔画问题。我们知道,如果一个图是欧拉图,那么只需要画一笔。首先求出这个图有多少个连通块,然后求出每个连通块需要画多少笔,最后每个连通块需要画的笔数加起来即为答案。对于每个连通块,若所有点的度数都为偶数,则是欧拉图,只需画一笔;否则,需要画的笔数为 奇度数点的数目/2.
 
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <queue>
#include <vector>
#include <cmath>
#include <map>
#include <cstdlib>
#define L(rt) (rt<<1)
#define R(rt) (rt<<1|1)
#define ll long long
#define eps 1e-6
using namespace std;

const int maxn=100005;
int fa[maxn],d[maxn];
int cnt[maxn];
int n,m;
void init()
{
    for(int i=1; i<=n; i++) fa[i]=i;
    memset(d,0,sizeof(d));
    memset(cnt,0,sizeof(cnt));
}
int find_set(int x)
{
    return x==fa[x]?x:fa[x]=find_set(fa[x]);
}
void Union(int a,int b)
{
    int ra=find_set(a);
    int rb=find_set(b);
    if(ra==rb) return;
    fa[ra]=rb;
}
int main()
{
    int a,b;
    while(~scanf("%d%d",&n,&m))
    {
        init();
        while(m--)
        {
            scanf("%d%d",&a,&b);
            Union(a,b);
            d[a]++;
            d[b]++;
        }
        for(int i=1; i<=n; i++)
            if(d[i]&1) cnt[find_set(i)]++;
        int ans=0;
        for(int i=1;i<=n;i++)
        if(fa[i]==i&&d[i])
        {
            if(!cnt[i]) ans++;
            else ans+=cnt[i]/2;
        }
        printf("%d\n",ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值