HDU 3018 Ant Trip 一笔画问题

点击打开链接

 

Ant Trip

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1110    Accepted Submission(s): 406


Problem Description
    Ant Country consist of N towns.There are M roads connecting the towns.

    Ant Tony,together with his friends,wants to go through every part of the country.

    They intend to visit every road , and every road must be visited for exact one time.However,it may be a mission impossible for only one group of people.So they are trying to divide all the people into several groups,and each may start at different town.Now tony wants to know what is the least groups of ants that needs to form to achieve their goal.
 


 

Input
Input contains multiple cases.Test cases are separated by several blank lines. Each test case starts with two integer N(1<=N<=100000),M(0<=M<=200000),indicating that there are N towns and M roads in Ant Country.Followed by M lines,each line contains two integers a,b,(1<=a,b<=N) indicating that there is a road connecting town a and town b.No two roads will be the same,and there is no road connecting the same town.
 


 

Output
For each test case ,output the least groups that needs to form to achieve their goal.
 


 

Sample Input
  
  
3 3 1 2 2 3 1 3 4 2 1 2 3 4
 


 

Sample Output
  
  
1 2
Hint
New ~~~ Notice: if there are no road connecting one town ,tony may forget about the town. In sample 1,tony and his friends just form one group,they can start at either town 1,2,or 3. In sample 2,tony and his friends must form two group.
 


 

Source
 


 

Recommend
gaojie

 

 

题意是说每一条边只能走一次,让你求至少画几笔才能全部通过。

首先,你用笔来画的话,只可能有2种,一:每回路,a——>b  二:形成回路,a——>...——>a。对于整副图(每一块块组合而成),等于 :第一块奇数点/2+第二块奇数点/2+.......,最后得,图的总奇数点/2。总之笔划数 = 奇度数%2 + 欧拉回路数。

 

#include<stdio.h>
#define M 100005
int pre[M],deg[M],ans[M];
int n,m;

void init()
{
    for(int i=1;i<=n;i++)
    {
        pre[i]=i;
        ans[i]=deg[i]=0;
    }
}

int find(int x)
{
    while(x!=pre[x])
        x=pre[x];
    return x;
}

void unio(int a,int b)
{
    int x=find(a);
    int y=find(b);
    if(x==y)return;
    pre[x]=y;
}

int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        init();
        int a,b;
        while(m--)
        {
            scanf("%d%d",&a,&b);
            deg[a]++;
            deg[b]++;
            unio(a,b);
        }
        int sum=0;
        for(int i=1;i<=n;i++)
            if(deg[i]%2)//如果顶点数为奇数
            {
                ans[find(i)]++;
                sum++;
            }
        sum/=2;//含奇度顶点的图需要奇度顶点个数/2笔才能画完
        for(int i=1;i<=n;i++)
            if(find(i)==i)
            {
                if(ans[i]==0&°[i]!=0)//欧拉回路并且不为一个单独的点
                    sum++;
            }
        printf("%d\n",sum);
    }
    return 0;
}


 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值