poj 3070 Fibonacci(矩阵快速幂)

8 篇文章 0 订阅
Fibonacci
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7303 Accepted: 5186

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.

 
 
题意:用矩阵乘法来求Fibonacci数列。
分析:矩阵快速幂
 
AC代码;
#include <cstring>
#include <string>
#include <cstdio>
#include <algorithm>
#include <queue>
#include <cmath>
#include <vector>
#include <cstdlib>
#include <iostream>

using namespace std;
typedef struct node
{
    int m[2][2];
    void init()
    {
        m[0][0]=m[0][1]=m[1][0]=1;
        m[1][1]=0;
    }
}matrix;
int n;
matrix matrix_multi(matrix a,matrix b)
{
    matrix temp;
    for(int i=0;i<2;i++)
    for(int j=0;j<2;j++)
    {
        temp.m[i][j]=0;
        for(int k=0;k<2;k++)
        temp.m[i][j]+=a.m[i][k]*b.m[k][j];
        if(temp.m[i][j]>10000)
        temp.m[i][j]%=10000;
    }
    return temp;
}
int main()
{
    while(cin>>n)
    {
        if(n==-1) break;
        matrix r,a;
        r.m[1][0]=r.m[0][1]=0;  //将r设为单位矩阵(主对角线为1,其余为0,任何矩阵与之相乘得到其本身)
        r.m[0][0]=r.m[1][1]=1;
        a.init();
        while(n)
        {
            if(n&1)
            r=matrix_multi(r,a);
            a=matrix_multi(a,a);
            n>>=1;
        }
        cout<<r.m[1][0]<<endl;
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值