杭电ACM1009(老鼠找猫换javabean…

 

Problem Description

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

Input

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.

Output

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

Sample Input

5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1

Sample Output

13.333
31.500
代码如下:

 

#include<stdio.h>
int main()
{
int m ,n , i , j;
double a [ 1000 ],b [ 1000 ], c [ 1000 ], t , sum = 0;
while( scanf( "%d%d" , & m , &n) &&( m !=- 1||n !=- 1))
{
  for( i = 0; i <n; i ++)
    scanf( "%lf%lf" , & a [ i ], &b [ i ]);
  for( i = 0; i <n; i ++)
    if(b [ i ] == 0 ){ sum = sum + a [ i ];b [ i ] =- 1 ;} //-1没有具体意思,只是确定不是0而已!
  for( i = 0; i <n; i ++)
    c [ i ] = a [ i ] /b [ i ];
  for( j = 0; j <n - 1; j ++          //冒泡排序,控制n-1次循环,实现n-1次比较
    for( i = 0; i <n - 1 - j; i ++)
      if( c [ i ] < c [ i + 1 ])
    {
      t = c [ i ]; c [ i ] = c [ i + 1 ]; c [ i + 1 ] = t;
      t = a [ i ]; a [ i ] = a [ i + 1 ]; a [ i + 1 ] = t; t =b [ i ];
      b [ i ] =b [ i + 1 ];b [ i + 1 ] = t;
      }
  for( i = 0; i <n; i ++)
  {
    if(b [ i ] !=- 1)
    {
      if( m >=b [ i ]){ m = m -b [ i ]; sum = sum + a [ i ];}  //先将大比例对应的javabean先取完,然后用m存储剩下的的猫粮数
      else { sum = sum + c [ i ] * m; break ;}  //当猫粮数小于小比例的仓库的猫粮数时,计算出每份猫粮能换的javabean,再乘剩下的猫粮数,加上sum得到javabean数
    }
  }
  printf( "%.3lf \n " , sum);
  sum = 0;
}
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值