POJ 3255 Roadblocks 求次短路

A - Roadblocks
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

Description

Bessie has moved to a small farm and sometimes enjoys returning to visit one of her best friends. She does not want to get to her old home too quickly, because she likes the scenery along the way. She has decided to take the second-shortest rather than the shortest path. She knows there must be some second-shortest path.

The countryside consists of R (1 ≤ R ≤ 100,000) bidirectional roads, each linking two of the N (1 ≤ N ≤ 5000) intersections, conveniently numbered 1..N. Bessie starts at intersection 1, and her friend (the destination) is at intersection N.

The second-shortest path may share roads with any of the shortest paths, and it may backtrack i.e., use the same road or intersection more than once. The second-shortest path is the shortest path whose length is longer than the shortest path(s) (i.e., if two or more shortest paths exist, the second-shortest path is the one whose length is longer than those but no longer than any other path).

Input

Line 1: Two space-separated integers:  N and  R 
Lines 2..  R+1: Each line contains three space-separated integers:  AB, and  D that describe a road that connects intersections  A and  B and has length D (1 ≤  D ≤ 5000)

Output

Line 1: The length of the second shortest path between node 1 and node  N

Sample Input

4 4
1 2 100
2 4 200
2 3 250
3 4 100

Sample Output

450

Hint

Two routes: 1 -> 2 -> 4 (length 100+200=300) and 1 -> 2 -> 3 -> 4 (length 100+250+100=450)



题目大意:在一个图上有许多个农场,有个人从1农场出发,
到他的朋友n农场去,他不想走一条最短路径,这次他想换条路走,
要你帮他找一条次短路径,次短路的定义是,比最短路径长度短(可能有多条),
但是不会比其他的路径长度长。而且告诉你数据中一定存在至少一条次短路。

利用最短路的思想,最短路是维护每个节点到起点的最短距离,
依次确定尚未确定的顶点中距离最小的那个顶点 

根据次短路定义,从S到u的第二短的路线,那么只要维护一下次短路就可以了。
新的节点次短路要么是 S->u最的短路再加上u->v的边 
要么是 S->u的次短路加上u->v的边 
就是{dis1[e.v], dis2[e.v]+e.w}里面最短的是最短路 第二小的是次短路

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <queue>
#include <vector>
#include <cmath>
#include <stack>
#include <string>
#include <map>
#include <set>
#define pi acos(-1)
#define LL long long
#define INF 0x3f3f3f3f
using namespace std;
typedef pair<int, int> P;
const int maxn = 1e5 + 5;

struct edge{
    int v, w;
    edge(int v_, int w_){
        v = v_; w = w_;
    }
};
vector<edge>G[maxn];
int dis1[maxn]; // 最短路 
int dis2[maxn]; // 次短路 
int n, m;
void dijkstra(int s)
{
    priority_queue<P, vector<P>, greater<P> > q;
    for (int i = 1; i <= n; i++){
        dis1[i] = INF;
        dis2[i] = INF;
    }
    dis1[s] = 0;
    q.push(P(dis1[s], s));
    while (!q.empty())
    {
        P cur = q.top(); q.pop();
        int u = cur.second;
        int w = cur.first;
        if (dis2[u] < w) continue;
        for (int i = 0; i < G[u].size(); i++){
            edge e = G[u][i];
            int cur_w = w + e.w; // 新的权值 
            if (dis1[e.v] > cur_w){ // 维护最短路 
//                dis1[e.v] = cur_w;
                swap(dis1[e.v], cur_w); // 这里是交换值 
                q.push(P(dis1[e.v], e.v));
            }
            if (dis2[e.v] > cur_w && dis1[e.v] < cur_w){ // 维护次短路 
                dis2[e.v] = cur_w;
                q.push(P(dis2[e.v], e.v));
            }
        }
    }
}
int main(void)
{
//	freopen("C:\\Users\\wave\\Desktop\\NULL.exe\\NULL\\in.txt","r", stdin);
    int i, j, k, u, v, w;
    while (cin >> n >> m)
    {
        for (i = 1; i <= n; i++) G[i].clear();
        for (i = 1; i <= m; i++){
            scanf("%d %d %d", &u, &v, &w);
            G[u].push_back(edge(v, w));
            G[v].push_back(edge(u, w));
        }
        dijkstra(1);
        cout << dis2[n] << endl;
    }

	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值