1136 A Delayed Palindrome(20 分)

Consider a positive integer N written in standard notation with k+1 digits a​i​​ as a​k​​⋯a​1​​a​0​​with 0≤a​i​​<10 for all i and a​k​​>0. Then N is palindromic if and only if a​i​​=a​k−i​​ for all i. Zero is written 0 and is also palindromic by definition.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. Such number is called a delayed palindrome. (Quoted from https://en.wikipedia.org/wiki/Palindromic_number )

Given any positive integer, you are supposed to find its paired palindromic number.

Input Specification:

Each input file contains one test case which gives a positive integer no more than 1000 digits.

Output Specification:

For each test case, print line by line the process of finding the palindromic number. The format of each line is the following:

A + B = C

where A is the original number, B is the reversed A, and C is their sum. A starts being the input number, and this process ends until C becomes a palindromic number -- in this case we print in the last line C is a palindromic number.; or if a palindromic number cannot be found in 10 iterations, print Not found in 10 iterations. instead.

Sample Input 1:

97152

Sample Output 1:

97152 + 25179 = 122331
122331 + 133221 = 255552
255552 is a palindromic number.

Sample Input 2:

196

Sample Output 2:

196 + 691 = 887
887 + 788 = 1675
1675 + 5761 = 7436
7436 + 6347 = 13783
13783 + 38731 = 52514
52514 + 41525 = 94039
94039 + 93049 = 187088
187088 + 880781 = 1067869
1067869 + 9687601 = 10755470
10755470 + 07455701 = 18211171
Not found in 10 iterations.

 

很简单的一题,这个就是相当于大数的加法运算了,对字符串的处理

其实is函数不用也可以,就s的倒置然后比较也可以

 

#include<iostream>
#include<cstdio>
#include<string>
#include<algorithm>
#include<map>
#include<vector>
using namespace std;
bool is(string s)
{
	for (int i = 0;i < s.size() / 2;i++) {
		if (s[i] != s[s.size() - 1 - i]) return false;
	}
	return true;
}

string change(string s1)
{
	string s = s1;
	reverse(s1.begin(), s1.end());
	string t = s1;
	string ans;
	ans = s;
	int carry = 0;
	//cout << ans << "       " << s << "          " << t << "fdsaa" << endl;
	for (int i = s.size() - 1;i >= 0;i--) {
		ans[i] = (s[i] - '0' + t[i] - '0' + carry) % 10 + '0';
		carry = (s[i] - '0' + t[i] - '0' + carry) / 10;
	}
	if (carry) ans = '1' + ans;
	return ans;
}
int main()
{
	string s;
	cin >> s;
	if (s == "0") printf("0\n");
	else {
		string t = s;
		for (int i = 0;i < 10;i++) {
			if (is(t)) {
				cout << t << " is a palindromic number." << endl;
				return 0;
			}
			string t1 = t;
			string t2;
			reverse(t.begin(), t.end());
			t2 = t;
			//cout << t1 << endl;
			t = change(t1);
			cout << t1 << " + " << t2 << " = " << t << endl;
		}
	}
	cout << "Not found in 10 iterations." << endl;
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值