求二叉树的先序遍历

求二叉树的先序遍历

Time Limit: 1000MS  Memory Limit: 65536KB
Problem Description
 已知一棵二叉树的中序遍历和后序遍历,求二叉树的先序遍历
Input
 输入数据有多组,第一行是一个整数t (t<1000),代表有t组测试数据。每组包括两个长度小于50 的字符串,第一个字符串表示二叉树的中序遍历序列,第二个字符串表示二叉树的后序遍历序列。 
Output
 输出二叉树的先序遍历序列
Example Input
2
dbgeafc
dgebfca
lnixu
linux
Example Output
abdegcf
xnliu
代码如下
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
struct node
{
    int data;
    struct node *left;
    struct node *right;
};
struct node *creat(int n,char *z,char *h)
{
    int i;
    struct node *tree;
    tree=(struct node *)malloc(sizeof(struct node));
    if(n==0)
        return NULL;
    tree->data=h[n-1];
    for(i=0; i<n; i++)
    {
        if(z[i]==h[n-1])
        {
            break;
        }
    }
    printf("%c",tree->data);
    tree->left=creat(i,z,h);
    tree->right=creat(n-i-1,z+i+1,h+i);
    return tree;
};
int main()
{
    int n,t;
    char x[100];
    char z[100];
    scanf("%d",&t);
    while(t--)
    {
        scanf("%s",z);
        scanf("%s",x);
        n=strlen(x);
        creat(n,z,x);
        printf("\n");


    }
    return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值