hdu 畅通工程再续(最小生成树---Kruscal)

畅通工程再续

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 3   Accepted Submission(s) : 2
Font: Times New Roman | Verdana | Georgia
Font Size:  

Problem Description

相信大家都听说一个“百岛湖”的地方吧,百岛湖的居民生活在不同的小岛中,当他们想去其他的小岛时都要通过划小船来实现。现在政府决定大力发展百岛湖,发展首先要解决的问题当然是交通问题,政府决定实现百岛湖的全畅通!经过考察小组RPRush对百岛湖的情况充分了解后,决定在符合条件的小岛间建上桥,所谓符合条件,就是2个小岛之间的距离不能小于10米,也不能大于1000米。当然,为了节省资金,只要求实现任意2个小岛之间有路通即可。其中桥的价格为 100元/米。

Input

输入包括多组数据。输入首先包括一个整数T(T <= 200),代表有T组数据。
每组数据首先是一个整数C(C <= 100),代表小岛的个数,接下来是C组坐标,代表每个小岛的坐标,这些坐标都是 0 <= x, y <= 1000的整数。

Output

每组输入数据输出一行,代表建桥的最小花费,结果保留一位小数。如果无法实现工程以达到全部畅通,输出”oh!”.

Sample Input

2
2
10 10
20 20
3
1 1
2 2
1000 1000

Sample Output

1414.2
oh!

Author

8600

Source

2008浙大研究生复试热身赛(2)——全真模拟


这道题用prim会快一些,因为和Kruscal比很多边都不用再算了
超时一次,因为代码中有个地方写的浪费了很多时间,特此留意

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <math.h>
#define D(i,j) sqrt(pow((pos[i].x - pos[j].x),2.0) + pow(pos[i].y - pos[j].y,2.0))
using namespace std;


struct Node{
    int x,y;
    double w;
}d[10005];
struct Nod{
    int x,y;
}pos[105];
int pre[105];


int cmp(Node a,Node b){
    return a.w < b.w;
}

int Find(int x){
    int p = x;
    while(pre[p] != p)
        p = pre[p];
    int i = x;
    while(pre[i] != i){
        int j = pre[i];
        pre[i] = p;
        i = j;
    }
    return p;
}


int main(){
    int t,n;
    int i,j;
    double sum;
    int countn,countt;

    scanf("%d",&t);
    while(t--){
        memset(d,0,sizeof(d));
        sum = 0;
        for(i = 0;i < 105;i++)
            pre[i] = i;
        countt = 0;
        countn = 0;
        scanf("%d",&n);
        for(i = 0;i < n;i++)
            scanf("%d%d",&pos[i].x,&pos[i].y);
        for(i = 0;i < n;i++)
            for(j = 0;j < n;j++){
                double tem = D(i,j);//先得到tem值,再对tem进行比较,否则每次都算一遍浪费很多时间
                if((tem >= 10.000000 && tem <= 1000.0000001)){
                    d[countt].x = i;
                    d[countt].y = j;
                    d[countt].w = tem;
                    countt++;
                }
            }
        sort(d,d + countt,cmp);
        for(i = 0;i < countt;i++){
            if(Find(d[i].x) != Find(d[i].y)){
                if(countn == 0)
                    countn = 2;
                else
                    countn++;
                sum += d[i].w;
                pre[Find(d[i].x)] = Find(d[i].y);
            }
        }
        if(countn == n)
            printf("%.1lf\n",sum * 100);
        else
            printf("oh!\n");
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值