uva 10047 - The Monocycle(Bfs)

Problem A: The Monocycle

A monocycle is a cycle that runs on one wheel and the one we will be considering is a bit more special. It has a solid wheel colored with five different colors as shown in the figure:

The colored segments make equal angles (72o) at the center. A monocyclist rides this cycle on an $M \times N$ grid of square tiles. The tiles have such size that moving forward from the center of one tile to that of the next one makes the wheel rotate exactly 72o around its own center. The effect is shown in the above figure. When the wheel is at the center of square 1, the mid­point of the periphery of its blue segment is in touch with the ground. But when the wheel moves forward to the center of the next square (square 2) the mid­point of its white segment touches the ground.

Some of the squares of the grid are blocked and hence the cyclist cannot move to them. The cyclist starts from some square and tries to move to a target square in minimum amount of time. From any square either he moves forward to the next square or he remains in the same square but turns 90o left or right. Each of these actions requires exactly 1 second to execute. He always starts his ride facing north and with the mid­point of the green segment of his wheel touching the ground. In the target square, too, the green segment must be touching the ground but he does not care about the direction he will be facing.

Before he starts his ride, please help him find out whether the destination is reachable and if so the minimum amount of time he will require to reach it.

Input

The input may contain multiple test cases.

The first line of each test case contains two integers M and N ($1 \le M$, $N \le 25$) giving the dimensions of the grid. Then follows the description of the grid in M lines of N characters each. The character `#' will indicate a blocked square, all other squares are free. The starting location of the cyclist is marked by `S' and the target is marked by `T'. The input terminates with two zeros for M and N.

Output

For each test case in the input first print the test case number on a separate line as shown in the sample output. If the target location can be reached by the cyclist print the minimum amount of time (in seconds) required to reach it exactly in the format shown in the sample output, otherwise, print ``destination not reachable".

Print a blank line between two successive test cases.

Sample Input

1 3
S#T
10 10
#S.......#
#..#.##.##
#.##.##.##
.#....##.#
##.##..#.#
#..#.##...
#......##.
..##.##...
#.###...#.
#.....###T
0 0

Sample Output

Case #1
destination not reachable
 
Case #2
minimum time = 49 sec



Miguel Revilla
2000-12-26

这道题的巧妙之处在于把每个节点拆分成(x,y,d,c)这样的状态。
然后注意输出时,每相邻两组数据输出一个空行(不是每组后面一个空行)

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
using namespace std;

const int INF = 10000000;
const int maxm = 25 + 5;
const int maxn = 25 + 5;
char map[maxm][maxn];
int sx,sy,tx,ty,M,N;

int vis[maxm][maxn][5][4];
const int Dirx[] = {-1,0,1,0};
const int Diry[] = {0,1,0,-1};
int ans,Count,t;
struct Node{
    int x,y,color,dir,t;
    Node(int x,int y,int color,int dir,int t):x(x),y(y),color(color),dir(dir),t(t){}
};
queue<Node> q;

void init(){
    ans = INF;
    Count = 0;
    while(!q.empty())
        q.pop();
    memset(vis,0,sizeof(vis));
}

void Bfs(){
    while(!q.empty()){
        int x = q.front().x;
        int y = q.front().y;
        int color = q.front().color;
        int dir = q.front().dir;
        int t = q.front().t;
        if(x == tx && y == ty && color == 0){
            Count++;
            ans = min(ans,t);
        }
        if(Count >= 4)
            break;
        q.pop();
        if(!vis[x][y][color][(dir+5)%4]){
            q.push(Node(x,y,color,(dir+5)%4,t+1));
            vis[x][y][color][(dir+5)%4] = 1;
        }
        if(!vis[x][y][color][(dir+3)%4]){
            q.push(Node(x,y,color,(dir+3)%4,t+1));
            vis[x][y][color][(dir+3)%4] = 1;
        }
        int nx = x + Dirx[dir];
        int ny = y + Diry[dir];
        if(nx >= 0 && nx < M && ny >= 0 && ny < N && !vis[nx][ny][(color+1)%5][dir] && map[nx][ny] != '#'){
            q.push(Node(nx,ny,(color+1)%5,dir,t+1));
            vis[nx][ny][(color+1)%5][dir] = 1;
        }
    }
}

int main(){
    t = 1;
    while(scanf("%d%d",&M,&N)){
        if(M == 0 && N == 0)
            break;
        if(t != 1)  printf("\n");
        printf("Case #%d\n",t++);

        for(int i = 0;i < M;i++){
            scanf("%s",map[i]);
            for(int j = 0;j < N;j++){
                if(map[i][j] == 'S'){
                    sx = i;sy = j;
                }
                else if(map[i][j] == 'T'){
                    tx = i;ty = j;
                }
            }
        }
        init();
        q.push(Node(sx,sy,0,0,0));
        vis[sx][sy][0][0] = 1;
        Bfs();
        if(ans == INF)
            printf("destination not reachable\n");
        else
            printf("minimum time = %d sec\n",ans);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值