uva 1423 - Guess(拓扑排序)

Given a sequence of integers, a1, a2,..., an , we define its sign matrix S such that, for 1$ \le$i$ \le$j$ \le$n , Sij = `` + " if Sij = `` - " if ai +...+ aj < 0 ; and Sij = ``0" otherwise.

For example, if (a1, a2, a3, a4) = (- 1, 5, - 4, 2) , then its sign matrix S is a 4×4 matrix:


 1234
1-+0+
2 +++
3  --
4   +


We say that the sequence (-1, 5, -4, 2) generates the sign matrix. A sign matrix is valid if it can be generated by a sequence of integers.

Given a sequence of integers, it is easy to compute its sign matrix. This problem is about the opposite direction: Given a valid sign matrix, find a sequence of integers that generates the sign matrix. Note that two or more different sequences of integers can generate the same sign matrix. For example, the sequence (-2, 5, -3, 1) generates the same sign matrix as the sequence (-1,5, -4,2).

Write a program that, given a valid sign matrix, can find a sequence of integers that generates the sign matrix. You may assume that every integer in a sequence is between -10 and 10, both inclusive.

Input

Your program is to read from standard input. The input consists of T test cases. The number of test cases T is given in the first line of the input. Each test case consists of two lines. The first line contains an integer n (1$ \le$n$ \le$10) , where n is the length of a sequence of integers. The second line contains a string of n(n + 1)/2 characters such that the first n characters correspond to the first row of the sign matrix, the next n - 1 characters to the second row, ... , and the last character to the n -th row.

Output

Your program is to write to standard output. For each test case, output exactly one line containing a sequence of n integers which generates the sign matrix. If more than one sequence generates the sign matrix, you may output any one of them. Every integer in the sequence must be between -10 and 10, both inclusive.

Sample Input

3 
4 
-+0++++--+ 
2 
+++ 
5 
++0+-+-+--+-+--

Sample Output

-2 5 -3 1 
3 4 
1 2 -3 4 -5

这道题很容易转化成:
已知s[0],s[1]...s[n]的大小关系,求a[1],a[2]...a[n]的值
不要想直接转化得到数列a的大小关系,那样不好找。而已知s后,可以直接用s[n]-s[n-1]求a[n];
并且只要让相邻的s相差为1,a的值的绝对值就不会超过10.
然后拓扑排序时先找到所有入度为0的点后,再进行“减度”。

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

int n;
int const maxn = 10 + 5;

int degree[maxn];
int map[maxn][maxn];
int s[maxn],ans[maxn];
char text[1000];

void init(){
    memset(map,0,sizeof(map));
    memset(degree,0,sizeof(degree));
}

void topsort(){
    int count = 0,low = -10;
    while(count != n+1){
        int tag[maxn];
        memset(tag,0,sizeof(tag));
        for(int i = 0;i <= n;i++){
            if(degree[i] == 0){
                s[i] = low;
                degree[i] = -1;
                tag[i] = 1;
                count++;
            }
        }
        low++;
        for(int i = 0;i <= n;i++){
            if(tag[i]){
                for(int j = 0;j <= n;j++){
                    if(map[i][j])
                        degree[j]--;
                }
            }
        }
    }
}

int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        scanf("%d%s",&n,text);
        init();
        char f;
        int idx = 0;
        for(int i = 1;i <= n;i++){
            for(int j = i;j <= n;j++){
                f = text[idx++];
                if(f == '+'){
                    map[i-1][j] = 1;
                    degree[j]++;
                }
                else if(f == '-'){
                    map[j][i-1] = 1;
                    degree[i-1]++;
                }
            }
        }
        topsort();
        for(int i = 1;i <= n;i++){
            ans[i] = s[i] - s[i-1];
        }
        for(int i = 1;i < n;i++)
            printf("%d ",ans[i]);
        printf("%d\n",ans[n]);
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
智慧校园整体解决方案是响应国家教育信息化政策,结合教育改革和技术创新的产物。该方案以物联网、大数据、人工智能和移动互联技术为基础,旨在打造一个安全、高效、互动且环保的教育环境。方案强调从数字化校园向智慧校园的转变,通过自动数据采集、智能分析和按需服务,实现校园业务的智能化管理。 方案的总体设计原则包括应用至上、分层设计和互联互通,确保系统能够满足不同用户角色的需求,并实现数据和资源的整合与共享。框架设计涵盖了校园安全、管理、教学、环境等多个方面,构建了一个全面的校园应用生态系统。这包括智慧安全系统、校园身份识别、智能排课及选课系统、智慧学习系统、精品录播教室方案等,以支持个性化学习和教学评估。 建设内容突出了智慧安全和智慧管理的重要性。智慧安全管理通过分布式录播系统和紧急预案一键启动功能,增强校园安全预警和事件响应能力。智慧管理系统则利用物联网技术,实现人员和设备的智能管理,提高校园运营效率。 智慧教学部分,方案提供了智慧学习系统和精品录播教室方案,支持专业级学习硬件和智能化网络管理,促进个性化学习和教学资源的高效利用。同时,教学质量评估中心和资源应用平台的建设,旨在提升教学评估的科学性和教育资源的共享性。 智慧环境建设则侧重于基于物联网的设备管理,通过智慧教室管理系统实现教室环境的智能控制和能效管理,打造绿色、节能的校园环境。电子班牌和校园信息发布系统的建设,将作为智慧校园的核心和入口,提供教务、一卡通、图书馆等系统的集成信息。 总体而言,智慧校园整体解决方案通过集成先进技术,不仅提升了校园的信息化水平,而且优化了教学和管理流程,为学生、教师和家长提供了更加便捷、个性化的教育体验。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值