Poj 1740(男人八题——博弈)

A New Stone Game
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 4448 Accepted: 2399

Description

Alice and Bob decide to play a new stone game.At the beginning of the game they pick n(1<=n<=10) piles of stones in a line. Alice and Bob move the stones in turn.
At each step of the game,the player choose a pile,remove at least one stones,then freely move stones from this pile to any other pile that still has stones.
For example:n=4 and the piles have (3,1,4,2) stones.If the player chose the first pile and remove one.Then it can reach the follow states.
2 1 4 2
1 2 4 2(move one stone to Pile 2)
1 1 5 2(move one stone to Pile 3)
1 1 4 3(move one stone to Pile 4)
0 2 5 2(move one stone to Pile 2 and another one to Pile 3)
0 2 4 3(move one stone to Pile 2 and another one to Pile 4)
0 1 5 3(move one stone to Pile 3 and another one to Pile 4)
0 3 4 2(move two stones to Pile 2)
0 1 6 2(move two stones to Pile 3)
0 1 4 4(move two stones to Pile 4)
Alice always moves first. Suppose that both Alice and Bob do their best in the game.
You are to write a program to determine who will finally win the game.

Input

The input contains several test cases. The first line of each test case contains an integer number n, denoting the number of piles. The following n integers describe the number of stones in each pile at the beginning of the game, you may assume the number of stones in each pile will not exceed 100.
The last test case is followed by one zero.

Output

For each test case, if Alice win the game,output 1,otherwise output 0.

Sample Input

3
2 1 3
2
1 1
0

Sample Output

1
0

Source

LouTiancheng@POJ

开始的想法就是按照博弈的基本思路:如果某个状态是必胜状态,就是它的下一步存在一个必败状态;如果某个状态是必败状态,那么说明它的下一步的每一步都是必胜状态。然后按照堆数来讨论,1堆必胜;2堆,(n,n)的情况必败,其他必胜;重要的就是3堆了,要能发现一定可以把3堆的转化成2堆的必败状态,方法就是拿最多的那一堆分到另外两堆上,使其相等,多余的舍去,所以3堆必胜;4堆也很重要,如果是(a,a,b,b)的形式,一定使必败的,否则必胜,这样就有基本了结论了。这题真不好观察出来。
#include <cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
const int maxn = 100 + 5;

int a[maxn];

int main(){
    int n;
    while(scanf("%d",&n)){
        if(n == 0) break;
        for(int i = 0;i < n;i++){
            scanf("%d",&a[i]);
        }
        sort(a,a+n);
        if(n%2 == 1){
            printf("1\n");
            continue;
        }
        else{
            int tag = 1;
            for(int i = 0;i < n;i+=2){
                if(a[i] != a[i+1]) tag = 0;
            }
            if(tag == 0){
                printf("1\n");
            }
            else{
                printf("0\n");
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值