poj1459 Power Network(最大流)

Power Network
Time Limit: 2000MS Memory Limit: 32768K
Total Submissions: 25116 Accepted: 13083

Description

A power network consists of nodes (power stations, consumers and dispatchers) connected by power transport lines. A node u may be supplied with an amount s(u) >= 0 of power, may produce an amount 0 <= p(u) <= p max(u) of power, may consume an amount 0 <= c(u) <= min(s(u),c max(u)) of power, and may deliver an amount d(u)=s(u)+p(u)-c(u) of power. The following restrictions apply: c(u)=0 for any power station, p(u)=0 for any consumer, and p(u)=c(u)=0 for any dispatcher. There is at most one power transport line (u,v) from a node u to a node v in the net; it transports an amount 0 <= l(u,v) <= l max(u,v) of power delivered by u to v. Let Con=Σ uc(u) be the power consumed in the net. The problem is to compute the maximum value of Con. 

An example is in figure 1. The label x/y of power station u shows that p(u)=x and p max(u)=y. The label x/y of consumer u shows that c(u)=x and c max(u)=y. The label x/y of power transport line (u,v) shows that l(u,v)=x and l max(u,v)=y. The power consumed is Con=6. Notice that there are other possible states of the network but the value of Con cannot exceed 6. 

Input

There are several data sets in the input. Each data set encodes a power network. It starts with four integers: 0 <= n <= 100 (nodes), 0 <= np <= n (power stations), 0 <= nc <= n (consumers), and 0 <= m <= n^2 (power transport lines). Follow m data triplets (u,v)z, where u and v are node identifiers (starting from 0) and 0 <= z <= 1000 is the value of l max(u,v). Follow np doublets (u)z, where u is the identifier of a power station and 0 <= z <= 10000 is the value of p max(u). The data set ends with nc doublets (u)z, where u is the identifier of a consumer and 0 <= z <= 10000 is the value of c max(u). All input numbers are integers. Except the (u,v)z triplets and the (u)z doublets, which do not contain white spaces, white spaces can occur freely in input. Input data terminate with an end of file and are correct.

Output

For each data set from the input, the program prints on the standard output the maximum amount of power that can be consumed in the corresponding network. Each result has an integral value and is printed from the beginning of a separate line.

Sample Input

2 1 1 2 (0,1)20 (1,0)10 (0)15 (1)20
7 2 3 13 (0,0)1 (0,1)2 (0,2)5 (1,0)1 (1,2)8 (2,3)1 (2,4)7
         (3,5)2 (3,6)5 (4,2)7 (4,3)5 (4,5)1 (6,0)5
         (0)5 (1)2 (3)2 (4)1 (5)4

Sample Output

15
6

Hint

The sample input contains two data sets. The first data set encodes a network with 2 nodes, power station 0 with pmax(0)=15 and consumer 1 with cmax(1)=20, and 2 power transport lines with lmax(0,1)=20 and lmax(1,0)=10. The maximum value of Con is 15. The second data set encodes the network from figure 1.

题意:n个结点,nc个用电点,对应一个最大用电量;np个发电站,对应一个最大发电量;m条电缆,对应一个最大传输量。求最后所有用电点的最大可用电量之和。

最大流建图,定一个源点,源点向发电站建边,权值为发电站对应的发电量;电缆建边,权值为电缆对应的传输量;用电点向汇点建边,权值为用电点对应的最大用电量。

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
#define maxn 105

using namespace std;

int n, np, nc, m;
int maps[maxn][maxn], q[maxn * maxn];
int d[maxn];//记录每个点所在的层

int BFS()//BFS分层,判断是否存在增广路
{
    memset(d, -1, sizeof(d));
    d[0] = 0;
    int f, r;
    f = 1;
    r = 1;
    q[r++] = 0;
    while(f < r)
    {
        int x = q[f++];
        for(int i = 1; i <= n + 1; i++)
        {
            if(d[i] < 0 && maps[x][i] > 0)
            {
                d[i] = d[x] + 1;
                q[r++] = i;
            }
        }
    }
    if(d[n + 1] > 0)
        return 1;
    else
        return 0;
}

int Find(int x, int v)//找出某一条增广路的最大流
{
    int a;
    if(x == n + 1)
        return v;
    for(int i = 1; i <= n + 1; i++)
    {
        if(maps[x][i] > 0 && d[i] == d[x] + 1 && (a = Find(i, min(v, maps[x][i]))))//x到i有流量 且 i是x的下一层 且 i到汇点存在最大流
        {
            maps[x][i] -= a;//增广路
            maps[i][x] += a;//回退边
            return a;
        }
    }
    return 0;
}


int main()
{
    int u, v, z;
    while(scanf("%d%d%d%d", &n, &np, &nc, &m) != EOF)
    {
        memset(maps, 0, sizeof(maps));
        for(int i = 0; i < m; i++)
        {
            scanf(" (%d,%d)%d", &u, &v, &z);
            maps[u + 1][v + 1] += z;
        }
        for(int i = 0; i < np; i++)
        {
            scanf(" (%d)%d", &u, &z);
            maps[0][u + 1] += z;
        }
        for(int i = 0; i < nc; i++)
        {
            scanf(" (%d)%d", &u, &z);
            maps[u + 1][n + 1] += z;
        }
        for(int i = 0; i <= n + 1; i++)
        {
            for(int j = 0; j <= n + 1; j++)
                printf("%d  ",maps[i][j]);
            printf("\n");
        }
        int ans = 0;
        int t = 0;
        while(BFS())//BFS搜索判断是否有从源点到汇点的通路
        {
            while(t = Find(0, 999999999))//查找增广路,求其最大流
                ans += t;
        }
        printf("%d\n", ans);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
图像识别技术在病虫害检测中的应用是一个快速发展的领域,它结合了计算机视觉和机器学习算法来自动识别和分类植物上的病虫害。以下是这一技术的一些关键步骤和组成部分: 1. **数据收集**:首先需要收集大量的植物图像数据,这些数据包括健康植物的图像以及受不同病虫害影响的植物图像。 2. **图像预处理**:对收集到的图像进行处理,以提高后续分析的准确性。这可能包括调整亮度、对比度、去噪、裁剪、缩放等。 3. **特征提取**:从图像中提取有助于识别病虫害的特征。这些特征可能包括颜色、纹理、形状、边缘等。 4. **模型训练**:使用机器学习算法(如支持向量机、随机森林、卷积神经网络等)来训练模型。训练过程中,算法会学习如何根据提取的特征来识别不同的病虫害。 5. **模型验证和测试**:在独立的测试集上验证模型的性能,以确保其准确性和泛化能力。 6. **部署和应用**:将训练好的模型部署到实际的病虫害检测系统中,可以是移动应用、网页服务或集成到智能农业设备中。 7. **实时监测**:在实际应用中,系统可以实时接收植物图像,并快速给出病虫害的检测结果。 8. **持续学习**:随着时间的推移,系统可以不断学习新的病虫害样本,以提高其识别能力。 9. **用户界面**:为了方便用户使用,通常会有一个用户友好的界面,显示检测结果,并提供进一步的指导或建议。 这项技术的优势在于它可以快速、准确地识别出病虫害,甚至在早期阶段就能发现问题,从而及时采取措施。此外,它还可以减少对化学农药的依赖,支持可持续农业发展。随着技术的不断进步,图像识别在病虫害检测中的应用将越来越广泛。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值