POJ-1459-Power Network(网络最大流)

Power Network
Time Limit: 2000MS Memory Limit: 32768K
Total Submissions: 27259 Accepted: 14172
Description

A power network consists of nodes (power stations, consumers and dispatchers) connected by power transport lines. A node u may be supplied with an amount s(u) >= 0 of power, may produce an amount 0 <= p(u) <= pmax(u) of power, may consume an amount 0 <= c(u) <= min(s(u),cmax(u)) of power, and may deliver an amount d(u)=s(u)+p(u)-c(u) of power. The following restrictions apply: c(u)=0 for any power station, p(u)=0 for any consumer, and p(u)=c(u)=0 for any dispatcher. There is at most one power transport line (u,v) from a node u to a node v in the net; it transports an amount 0 <= l(u,v) <= lmax(u,v) of power delivered by u to v. Let Con=Σuc(u) be the power consumed in the net. The problem is to compute the maximum value of Con.

这里写图片描述
An example is in figure 1. The label x/y of power station u shows that p(u)=x and pmax(u)=y. The label x/y of consumer u shows that c(u)=x and cmax(u)=y. The label x/y of power transport line (u,v) shows that l(u,v)=x and lmax(u,v)=y. The power consumed is Con=6. Notice that there are other possible states of the network but the value of Con cannot exceed 6.
Input

There are several data sets in the input. Each data set encodes a power network. It starts with four integers: 0 <= n <= 100 (nodes), 0 <= np <= n (power stations), 0 <= nc <= n (consumers), and 0 <= m <= n^2 (power transport lines). Follow m data triplets (u,v)z, where u and v are node identifiers (starting from 0) and 0 <= z <= 1000 is the value of lmax(u,v). Follow np doublets (u)z, where u is the identifier of a power station and 0 <= z <= 10000 is the value of pmax(u). The data set ends with nc doublets (u)z, where u is the identifier of a consumer and 0 <= z <= 10000 is the value of cmax(u). All input numbers are integers. Except the (u,v)z triplets and the (u)z doublets, which do not contain white spaces, white spaces can occur freely in input. Input data terminate with an end of file and are correct.
Output

For each data set from the input, the program prints on the standard output the maximum amount of power that can be consumed in the corresponding network. Each result has an integral value and is printed from the beginning of a separate line.
Sample Input

2 1 1 2 (0,1)20 (1,0)10 (0)15 (1)20
7 2 3 13 (0,0)1 (0,1)2 (0,2)5 (1,0)1 (1,2)8 (2,3)1 (2,4)7
(3,5)2 (3,6)5 (4,2)7 (4,3)5 (4,5)1 (6,0)5
(0)5 (1)2 (3)2 (4)1 (5)4
Sample Output

15
6
Hint

The sample input contains two data sets. The first data set encodes a network with 2 nodes, power station 0 with pmax(0)=15 and consumer 1 with cmax(1)=20, and 2 power transport lines with lmax(0,1)=20 and lmax(1,0)=10. The maximum value of Con is 15. The second data set encodes the network from figure 1.

题意:多组测试数据,每组测试数据给出N,Np,Nc,M。N代表结点数量,M代表边的数量,Np代表结点中电站的数量(只产电,不耗电),Nc代表消费者数量(只耗电,不产电),其他结点代表中转站(不产电,不耗电)。
接着M组(u,v)w数据,代表u到v容量为w,接着Np组(u)w,代表结点u产电w,接着Nc组(u)w,代表结点u耗电w。
求电网中能消耗的最大电能值。

思路:源点设为0,汇点设为N+1,鉴于u>=0,v>=0,构图时可以map[u+1][v+1]=w。源点到产电站的容量看成产电量,消费者到汇点的容量看作消费者的耗电量,直接求流入汇点的最大流即可,这里用的是标号法。

代码

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<queue>
using namespace std;
//先用标号法再用预留推进发
const int maxn=105;
const int INF=0x3f3f3f3f;
struct node
{
    int c;//容量
    int f;//流量
} map[maxn][maxn];
int point_star;//源点
int point_end;//汇点
int path[maxn];
int alpha[maxn];
int vis[maxn];
int N;//结点数量
int Np;//电站数量,产生电能
int Nc;//消费者数量,消耗电能
int M;//电线数量,网络容量
int Find_Path()//返回可改进量
{
    memset(path,-1,sizeof(path));
    memset(alpha,0,sizeof(alpha));
    memset(vis,0,sizeof(vis));
    path[point_star]=point_star;
    alpha[point_star]=INF;
    vis[point_star]=1;
    queue<int>q;
    q.push(point_star);
//    printf("%d\n",point_star);
    while(!q.empty())
    {
        int star=q.front();
        q.pop();
        for(int i=0; i<=point_end; i++)
        {
            if(vis[i]==0)
            {
                if(map[star][i].c-map[star][i].f>0)
                {
                    path[i]=star;
                    alpha[i]=min(map[star][i].c-map[star][i].f,alpha[star]);
                    vis[i]=1;
                    q.push(i);
                }
                else if(map[i][star].f>0)//反向且有流量,貌似可以省略
                {
                    path[i]=star;
                    alpha[i]=min(map[i][star].f,alpha[star]);
                    vis[i]=1;
                    q.push(i);
                }
            }
        }
    }
    return alpha[point_end];
}
void Update_Path()//更新网络
{
    for(int i=point_end; i!=point_star; i=path[i])
    {
        if(map[path[i]][i].c-map[path[i]][i].f>0)
            map[path[i]][i].f+=alpha[point_end];
        else if(map[i][path[i]] .f>0)
            map[i][path[i]].f-=alpha[point_end];
    }
}
void Build_Map()//建图
{
    memset(map,0,sizeof(map));
    point_star=0;
    point_end=N+1;
    int num_M=0;//已接受M的数量
    char c;
    c=getchar();
    while(num_M<M)
    {
        if(c=='(')
        {
            int u=0,v=0,w=0;
            c=getchar();
            while(c>='0'&&c<='9')
            {
                u=u*10+(int)(c-'0');
                c=getchar();
            }
            c=getchar();
            while(c>='0'&&c<='9')
            {
                v=v*10+(int)(c-'0');
                c=getchar();
            }
            c=getchar();
            while(c>='0'&&c<='9')
            {
                w=w*10+(int)(c-'0');
                c=getchar();
            }
            num_M++;
//            printf("%d %d %d\n",u,v,w);
            map[u+1][v+1].c=w;
        }
        else
            c=getchar();
    }
    int num_Np=0;
    while(num_Np<Np)
    {
        if(c=='(')
        {
            int u=0,w=0;
            c=getchar();//接收左括号的下一位数字
            while(c>='0'&&c<='9')
            {
                u=u*10+(int)(c-'0');
                c=getchar();
            }
            c=getchar();//接收右括号后面的数字
            while(c>='0'&&c<='9')
            {
                w=w*10+(int)(c-'0');
                c=getchar();
            }
            num_Np++;
            map[point_star][u+1].c=w;//源点流出容量
//            printf("%d %d\n",u,w);
        }
        else
            c=getchar();
    }
    int num_Nc=0;
    while(num_Nc<Nc)
    {
        if(c=='(')
        {
            int u=0,w=0;
            c=getchar();//接收左括号右边的数字
            while(c>='0'&&c<='9')
            {
                u=u*10+(int)(c-'0');
                c=getchar();
            }
            c=getchar();//接收右括号右边的数字
            while(c>='0'&&c<='9')
            {
                w=w*10+(int)(c-'0');
                c=getchar();
            }
            num_Nc++;
            map[u+1][point_end].c=w;
//            printf("%d %d\n",u,w);
        }
        else
            c=getchar();
    }
}
int main()
{
    while(~scanf("%d%d%d%d",&N,&Np,&Nc,&M))
    {
        Build_Map();
        //接着是标号法
//        for(int i=0;i<=N+1;i++)
//        {
//            for(int j=0;j<=N+1;j++)
//                printf("%d   ",map[i][j].c);
//            printf("\n");
//        }//建图没错


        int max_flow=0;
        while(1)
        {
            int flag_flow=Find_Path();
//            printf("%d\n",flag_flow);
            if(flag_flow==0)
                break;
            max_flow+=flag_flow;
            Update_Path();
        }
        printf("%d\n",max_flow);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值