HDU - 2199 Can you solve this equation? (二分)

Can you solve this equation?

Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);

Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.

Sample Input
2
100
-4

Sample Output
1.6152
No solution!

题目大意:给定一个递增函数,问函数在0,100的闭区间上是否有与给定数字相等的函数值,若有则输出自变量的值。浮点数的二分

#include <iostream>
#include <cmath>
#include <algorithm>
#include <cstdio>

using namespace std;

double f(double x)
{
    double ans = 8*pow(x, 4) + 7*pow(x, 3) + 2*pow(x, 2) + 3*x + 6;
    return ans;
}

int main()
{
    int t;
    double y, lo, hi, mid;
    cin >> t;
    while(t--)
    {
        cin >> y;
        if(y>=6 && y<=f(100))
        {
            lo = 0;
            hi = 100;
            while(hi-lo>1e-8)//设置精度,防止死循环
            {
                mid = (hi+lo)/2.0;
                if(f(mid)>y)
                    hi = mid;//浮点数的二分不需要移动
                else
                    lo = mid;
            }
            printf("%.4lf\n", lo);
        }
        else
            cout << "No solution!" << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值