HDU - 2199 Can you solve this equation? 二分

Can you solve this equation?

Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);

Output

For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.

Sample Input

2
100
-4

Sample Output

1.6152
No solution!

这个题目唯一值得说的就是很明显这个函数单增,端点值也很好求,直接判断完之后二分就好,其它没啥好说的了

#include <cmath>
#include <iostream>
using namespace std;
double f(double x);
int main()
{
    int t,y;
    double min,max,mid;
    cin>>t;
    while(t--){
        cin>>y;
        if(y<6||y>=807020306){
            cout<<"No solution!"<<endl; 
        }else{
            min=0;
            max=100;
            do{
                mid=(min+max)/2;
                if(f(mid)>y){
                    max=mid;
                }else{
                    min=mid;
                }
            }while(fabs(f(mid)-y)>1e-6);
            printf("%.4f\n",mid);
        }
    }
    return 0;
}
double f(double x)
{
    return 8*pow(x,4) + 7*pow(x,3) + 2*pow(x,2) + 3*x + 6; 
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值