PAT甲级(Advanced Level) 1001 A+B Format

1001 A+B Format

分数 20

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −106≤a,b≤106. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

题意概述 

计算 a+b 并以标准格式输出总和 —— 即,数字必须用逗号分隔成三位一组(除非少于四位数字)。

题解

因为标准格式是从个位数字开始,每三个为一组(这个是个坑 一开始看题没发现这个 从正着写只拿了14分),所以要将计算后的数转化为字符串,并且反着模拟

最后将结果再反着输出

#include<bits/stdc++.h>
using namespace std;
#define ll long long
#define endl '\n'
ll a,b;
ll ans;
int main()
{
	ios::sync_with_stdio(0);
	cin.tie(0);
	cout.tie(0);
	cin>>a>>b;
	ans=a+b;
	string s=to_string(ans);
	reverse(s.begin(),s.end());
	string ss="";
	int op=0;
	for(int i=0;i<s.size();i++)
	{
		if(s[i]>='0'&&s[i]<='9')//判断是否是数字 不能算符号
		{
			op++;
		}
		
		ss+=s[i];
		if(op==3 && (s[i+1]>='0'&&s[i+1]<='9'))//达到一组条件后 且 下一个是数字而不是符号
		{
			ss+=',';
			op=0;
		}
	}
	reverse(ss.begin(),ss.end());
	cout<<ss<<endl;
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值