More is better

本文探讨了在项目复杂度较高的情况下,如何通过算法选择最优的团队成员进行合作,以达到最佳效果。通过实例分析,介绍了如何利用图论中的朋友关系网络来优化团队构成,确保团队成员间的间接联系也能形成有效的协作链。
摘要由CSDN通过智能技术生成

More is better

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 327680/102400 K (Java/Others)
Total Submission(s): 19855    Accepted Submission(s): 7289


Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex,  the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.
 

Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
 

Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep. 
 

Sample Input
  
  
4 1 2 3 4 5 6 1 6 4 1 2 3 4 5 6 7 8
 

Sample Output
  
  
4 2
Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect), then A and C are also friends(indirect). In the first sample {1,2,5,6} is the result. In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.
 

Author
lxlcrystal@TJU
 

Source
 

题目大意:先输入一个n,然后输入n组数,判断最大的朋友圈里面有几个人,规则是若A与B是朋友,B与C是朋友,则A与C也是朋友;
#include<iostream>
#define Size 10000001
using namespace std;
int father[Size],a[Size],max1;
int find(int x){
	while(x!=father[x])
	x=father[x];
	return x;
}
void merage(int x,int y){
	x=find(x);
	y=find(y);
	if(x==y)return;
	if(a[x]>=a[y]){
		father[y]=x;
		a[x]=a[x]+a[y];
		if(max1<a[x])max1=a[x];
	}
	else {
		father[x]=y;
		a[y]=a[x]+a[y];
		if(max1<a[y])max1=a[y];
	}
}
int main()
{
	int i,n,x,y;
	while(cin>>n){
		if(n==0){
			cout<<1<<endl;continue;
		}
		max1=0;
		for(i=0;i<n;i++)
		{
			father[i]=i;
			a[i]=1;
		}
		for(i=0;i<n;i++)
		{
			cin>>x>>y;
			merage(x,y);
		}
		cout<<max1<<endl;
	}
}
最近几天水的题够多了,该写点难度高点的题了--_--

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值