最短路:HDU1595

HDU1595:

 

find the longest of the shortest

Time Limit: 1000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5319    Accepted Submission(s): 1995


 

Problem Description

Marica is very angry with Mirko because he found a new girlfriend and she seeks revenge.Since she doesn't live in the same city, she started preparing for the long journey.We know for every road how many minutes it takes to come from one city to another.
Mirko overheard in the car that one of the roads is under repairs, and that it is blocked, but didn't konw exactly which road. It is possible to come from Marica's city to Mirko's no matter which road is closed.
Marica will travel only by non-blocked roads, and she will travel by shortest route. Mirko wants to know how long will it take for her to get to his city in the worst case, so that he could make sure that his girlfriend is out of town for long enough.Write a program that helps Mirko in finding out what is the longest time in minutes it could take for Marica to come by shortest route by non-blocked roads to his city.

 

 

Input

Each case there are two numbers in the first row, N and M, separated by a single space, the number of towns,and the number of roads between the towns. 1 ≤ N ≤ 1000, 1 ≤ M ≤ N*(N-1)/2. The cities are markedwith numbers from 1 to N, Mirko is located in city 1, and Marica in city N.
In the next M lines are three numbers A, B and V, separated by commas. 1 ≤ A,B ≤ N, 1 ≤ V ≤ 1000.Those numbers mean that there is a two-way road between cities A and B, and that it is crossable in V minutes.

 

 

Output

In the first line of the output file write the maximum time in minutes, it could take Marica to come to Mirko.

 

 

Sample Input

 

5 6 1 2 4 1 3 3 2 3 1 2 4 4 2 5 7 4 5 1 6 7 1 2 1 2 3 4 3 4 4 4 6 4 1 5 5 2 5 2 5 6 5 5 7 1 2 8 1 4 10 2 3 9 2 4 10 2 5 1 3 4 7 3 5 10

 

 

Sample Output

 

11

13

27

一题我以为枚举删边会超时的题目,其实题意很白了甚至提示得很清楚,就删掉最短路上的每一条边,然后跑一次dijkstra,找出最大值就行

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define N 1005 
#define INF 0x3f3f3f3f
int dis[N], c[N][N];
int pre[N], pre1[N];
bool vis[N];
int n, m;
void dijkstra(int s)
{
	for(int i = 1; i <= n; i++) dis[i] = INF;
	memset(vis, false, sizeof(vis));
	memset(pre, -1, sizeof(pre));
	dis[s] = 0;
	for(int i = 1; i <= n; i++)
	{
		int minn = INF;
		int k = -1;
		for(int j = 1; j <= n; j++) if(dis[j] < minn && !vis[j]) minn = dis[k = j];
		if(k == -1) break;
		vis[k] = true;
		for(int j = 1; j <= n; j++)
		{
			if(dis[j] > dis[k] + c[k][j] && !vis[j])
			{
				pre[j] = k;
				dis[j] = dis[k] + c[k][j];
			}
		}
	}
}
int main()
{
	while(~scanf("%d%d", &n, &m))
	{
		memset(c, INF, sizeof(c));
		for(int i = 0; i < m; i++)
		{
			int u, v, w;
			scanf("%d%d%d", &u, &v, &w);
			if(w < c[u][v])
			{
				c[u][v] = c[v][u] = w;
			}
		}
		dijkstra(n);
		int u = 1;
		while(u != -1)
		{
			pre1[u] = pre[u];
			u = pre[u];
		}
		int maxn = dis[1];
		u = 1;
		while(u != -1)
		{
			int t = c[u][pre1[u]];
			c[u][pre1[u]] = c[pre1[u]][u] = INF;
			dijkstra(n);
			if(dis[1] != INF)
				maxn = max(maxn, dis[1]);
			c[u][pre1[u]] = c[pre1[u]][u] = t;
			u = pre1[u];
		}
		printf("%d\n", maxn);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值