Poor God Water【矩阵快速幂】

Poor God Water
时间限制: 1 Sec 内存限制: 128 MB
提交: 102 解决: 50
[提交] [状态] [命题人:admin]
题目描述
God Water likes to eat meat, fish and chocolate very much, but unfortunately, the doctor tells him that some sequence of eating will make them poisonous.
Every hour, God Water will eat one kind of food among meat, fish and chocolate. If there are 3 continuous hours when he eats only one kind of food, he will be unhappy. Besides, if there are 3 continuous hours when he eats all kinds of those, with chocolate at the middle hour, it will be dangerous. Moreover, if there are 3 continuous hours when he eats meat or fish at the middle hour, with chocolate at other two hours, it will also be dangerous.
Now, you are the doctor. Can you find out how many different kinds of diet that can make God Water happy and safe during N hours? Two kinds of diet are considered the same if they share the same kind of food at the same hour. The answer may be very large, so you only need to give out the answer module 1000000007.

输入
The fist line puts an integer T that shows the number of test cases. (T≤1000)
Each of the next T lines contains an integer N that shows the number of hours. (1≤N≤10^10)

输出
For each test case, output a single line containing the answer.

样例输入
复制样例数据
3
3
4
15
样例输出
20
46
435170

题目大意:
假设鱼为 a a a,肉为 b b b,巧克力为 c c c,先输入一个数字 T T T,表示共有 T T T组测试数据,下面 T T T行每行输入一个整数 n n n,代表有 n n n个时刻,每个时刻可以吃一种食物,但不能连续三个小时吃同一种食物,即 a a a aaa aaa b b b bbb bbb c c c ccc ccc不合法,当在三个小时内三种食物都吃的话,巧克力不能放中间,即 a c b acb acb b c a bca bca不合法,还有就是 c a c cac cac b c b bcb bcb,问共有多少种吃法。

解题思路:
n = 1 n=1 n=1时,有 f [ 1 ] = 3 f[1]=3 f[1]=3种吃法,即 a , b , c a,b,c a,b,c
n = 2 n=2 n=2时,有 f [ 2 ] = 9 f[2]=9 f[2]=9种吃法,并假设
1 、 a a       2 、 b a       3 、 c a 1、aa\ \ \ \ \ 2、ba\ \ \ \ \ 3、ca 1aa     2ba     3ca
4 、 a b       5 、 b b       6 、 c b 4、ab\ \ \ \ \ 5、bb\ \ \ \ \ 6、cb 4ab     5bb     6cb
7 、 a c       8 、 b c       9 、 c c 7、ac\ \ \ \ \ 8、bc\ \ \ \ \ 9、cc 7ac     8bc     9cc
n = 3 n=3 n=3时,有 f [ 3 ] = 20 f[3]=20 f[3]=20种吃法
1 、 a a { b c       2 、 b a { a b c       3 、 c a { a b 1、aa\begin{cases}b \\c \end{cases}\ \ \ \ \ 2、ba\begin{cases}a\\b \\c \end{cases}\ \ \ \ \ 3、ca\begin{cases}a \\b \end{cases} 1aa{bc     2baabc     3ca{ab
4 、 a b { a b c       5 、 b b { a c       6 、 c b { a b 4、ab\begin{cases}a\\b \\c \end{cases}\ \ \ \ \ 5、bb\begin{cases}a \\c \end{cases}\ \ \ \ \ 6、cb\begin{cases}a \\b \end{cases} 4ababc     5bb{ac     6cb{ab
7 、 a c { a c       8 、 b c { b c       9 、 c c { a b 7、ac\begin{cases}a \\c \end{cases}\ \ \ \ \ 8、bc\begin{cases}b \\c \end{cases}\ \ \ \ \ 9、cc\begin{cases}a \\b \end{cases} 7ac{ac     8bc{bc     9cc{ab
n > = 3 n>=3 n>=3
其情况 1 1 1的个数有: f [ n − 1 ] . 2 + f [ n − 1 ] . 3 f[n-1].2+f[n-1].3 f[n1].2+f[n1].3
其情况 2 2 2的个数有: f [ n − 1 ] . 4 + f [ n − 1 ] . 5 + f [ n − 1 ] . 6 f[n-1].4+f[n-1].5+f[n-1].6 f[n1].4+f[n1].5+f[n1].6
其情况 3 3 3的个数有: f [ n − 1 ] . 7 + f [ n − 1 ] . 9 f[n-1].7+f[n-1].9 f[n1].7+f[n1].9
其情况 4 4 4的个数有: f [ n − 1 ] . 1 + f [ n − 1 ] . 2 + f [ n − 1 ] . 3 f[n-1].1+f[n-1].2+f[n-1].3 f[n1].1+f[n1].2+f[n1].3
其情况 5 5 5的个数有: f [ n − 1 ] . 4 + f [ n − 1 ] . 6 f[n-1].4+f[n-1].6 f[n1].4+f[n1].6
其情况 6 6 6的个数有: f [ n − 1 ] . 8 + f [ n − 1 ] . 9 f[n-1].8+f[n-1].9 f[n1].8+f[n1].9
其情况 7 7 7的个数有: f [ n − 1 ] . 1 + f [ n − 1 ] . 2 f[n-1].1+f[n-1].2 f[n1].1+f[n1].2
其情况 8 8 8的个数有: f [ n − 1 ] . 4 + f [ n − 1 ] . 5 f[n-1].4+f[n-1].5 f[n1].4+f[n1].5
其情况 9 9 9的个数有: f [ n − 1 ] . 7 + f [ n − 1 ] . 8 f[n-1].7+f[n-1].8 f[n1].7+f[n1].8
所以可得:
∣ f [ n ] . 1 f [ n ] . 2 f [ n ] . 3 f [ n ] . 4 f [ n ] . 5 f [ n ] . 6 f [ n ] . 7 f [ n ] . 8 f [ n ] . 9 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 ∣ = ∣ 1 1 1 1 1 1 1 1 1 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 ∣ × ∣ 0 0 0 1 0 0 1 0 0 1 0 0 1 0 0 1 0 0 1 0 0 1 0 0 0 0 0 0 1 0 0 1 0 0 1 0 0 1 0 0 0 0 0 1 0 0 1 0 0 1 0 0 0 0 0 0 1 0 0 0 0 0 1 0 0 0 0 0 1 0 0 1 0 0 1 0 0 1 0 0 0 ∣ n − 2 \begin{vmatrix} f[n].1 & f[n].2& f[n].3 & f[n].4 & f[n].5 & f[n].6 & f[n].7 & f[n].8 & f[n].9 \\ 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 \\ 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 \\ 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 \\ 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 \\ 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 \\ 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 \\ 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 \\ 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 \\ \end{vmatrix}=\begin{vmatrix} 1 & 1 & 1 & 1 & 1 & 1 & 1 & 1 & 1 \\ 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 \\ 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 \\ 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 \\ 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 \\ 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 \\ 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 \\ 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 \\ 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 & 0 \\ \end{vmatrix}\times\begin{vmatrix} 0 & 0 & 0 & 1 & 0 & 0 & 1 & 0 & 0 \\ 1 & 0 & 0 & 1 & 0 & 0 & 1 & 0 & 0 \\ 1 & 0 & 0 & 1 & 0 & 0 & 0 & 0 & 0 \\ 0 & 1 & 0 & 0 & 1 & 0 & 0 & 1 & 0 \\ 0 & 1 & 0 & 0 & 0 & 0 & 0 & 1 & 0 \\ 0 & 1 & 0 & 0 & 1 & 0 & 0 & 0 & 0 \\ 0 & 0 & 1 & 0 & 0 & 0 & 0 & 0 & 1 \\ 0 & 0 & 0 & 0 & 0 & 1 & 0 & 0 & 1 \\ 0 & 0 & 1 & 0 & 0 & 1 & 0 & 0 & 0 \\ \end{vmatrix}^{n-2} f[n].100000000f[n].200000000f[n].300000000f[n].400000000f[n].500000000f[n].600000000f[n].700000000f[n].800000000f[n].900000000=100000000100000000100000000100000000100000000100000000100000000100000000100000000×011000000000111000000000101111000000000101000000000011110000000000110000000000110n2
因此直接用矩阵快速幂计算即可

代码:

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#include <cstring>
#include <map>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>
#include <set>
#include <utility>
#include <sstream>
#include <iomanip>
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
#define inf 0x3f3f3f3f
#define rep(i,l,r) for(int i=l;i<=r;i++)
#define lep(i,l,r) for(int i=l;i>=r;i--)
#define ms(arr) memset(arr,0,sizeof(arr))
//priority_queue<int,vector<int> ,greater<int> >q;
const int maxn = (int)1e5 + 5;
const ll mod = 1e9+7;
struct node
{
	ll arr[9][9];
	node() {
		ms(arr);
	}
};
node mul(node a,node b) {
	node c;
	for(int i=0;i<9;i++) {
		for(int j=0;j<9;j++) {
			for(int k=0;k<9;k++) {
				c.arr[i][j]=(c.arr[i][j]+(a.arr[i][k]*b.arr[k][j])%mod+mod)%mod;
			}
		}
	}
	return c;
}
ll quickpow(ll n) {
	node base;
	base.arr[1][0]=1;base.arr[2][0]=1;
	base.arr[3][1]=1;base.arr[4][1]=1;base.arr[5][1]=1;
	base.arr[6][2]=1;base.arr[8][2]=1;
	base.arr[0][3]=1;base.arr[1][3]=1;base.arr[2][3]=1;
	base.arr[3][4]=1;base.arr[5][4]=1;
	base.arr[7][5]=1;base.arr[8][5]=1;
	base.arr[0][6]=1;base.arr[1][6]=1;
	base.arr[3][7]=1;base.arr[4][7]=1;
	base.arr[6][8]=1;base.arr[7][8]=1;
	node a;
	a.arr[0][0]=1;a.arr[0][1]=1;a.arr[0][2]=1;a.arr[0][3]=1;a.arr[0][4]=1;a.arr[0][5]=1;a.arr[0][6]=1;a.arr[0][7]=1;a.arr[0][8]=1;
	while(n) {
		if(n&1) a=mul(a,base);
		base=mul(base,base);
		n>>=1;
	}
	ll ans=0;
	for(int i=0;i<9;i++) {
		ans=(ans+a.arr[0][i])%mod;
	}
	return ans;
}
int main() 
{
    #ifndef ONLINE_JUDGE
    //freopen("in.txt", "r", stdin);
    #endif
    //freopen("out.txt", "w", stdout);
    //ios::sync_with_stdio(0),cin.tie(0);
    int T;
    scanf("%d",&T);
    while(T--) {
    	ll n;
    	scanf("%lld",&n);
    	if(n==1) printf("3\n");
    	else printf("%lld\n",quickpow(n-2));
    }
    return 0;
}
评论 4
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值