H电-Problem Archive-5105-Math Problem

Math Problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 586    Accepted Submission(s): 142


Problem Description
Here has an function:
   f(x)=|ax3+bx2+cx+d|(LxR)
Please figure out the maximum result of f(x).
 

Input
Multiple test cases(less than 100). For each test case, there will be only 1 line contains 6 numbers a, b, c, d, L and R.  (10a,b,c,d10,100LR100)
 

Output
For each test case, print the answer that was rounded to 2 digits after decimal point in 1 line.
 

Sample Input
  
  
1.00 2.00 3.00 4.00 5.00 6.00
 

Sample Output
  
  
310.00
 

Source

BestCoder Round #18






一道纯粹数学题,关于3次方函数求极致,运用求导以及简单的函数图像方面的知识。同数学求解的思路一样需要区分三种情况来做这道题目。






S

#include<stdio.h>
#include<math.h>
#include<stdlib.h>

int main()
{
    double a, b, c, d, L, R, x, ans;

    while(scanf("%lf%lf%lf%lf%lf%lf", &a, &b, &c, &d, &L, &R) != EOF)
    {
        ans = -1;
        if (a != 0)
        {
            if ((4 * b * b - 12 * a * c) >= 0)
            {
                x = (-2 * b + sqrt(4 * b * b - 12 * a * c)) / (6 * a);
                if (x >= L && x <= R)
                {
                    x = abs(a * x * x * x  + b * x * x + c * x + d);
                    if(x > ans) ans = x;
                }
                x = (-2 * b - sqrt(4 * b * b - 12 * a * c)) / (6 * a);
                if (x >= L && x <= R)
                {
                    x = abs(a * x * x * x  + b * x * x + c * x + d);
                    if(x > ans) ans = x;
                }
                x = abs(a * L * L * L  + b * L * L + c * L + d);
                if(x > ans) ans = x;
                x = abs(a * R * R * R  + b * R * R + c * R + d);
                if(x > ans) ans = x;
            }
            else
            {
                x = abs(a * L * L * L  + b * L * L + c * L + d);
                if(x > ans) ans = x;
                x = abs(a * R * R * R  + b * R * R + c * R + d);
                if(x > ans) ans = x;
            }
        }
        else if (a == 0 && b != 0)
        {
            x = -c / (2 * b);
            x = abs(a * x * x * x  + b * x * x + c * x + d);
            if(x > ans) ans = x;
            x = abs(a * L * L * L  + b * L * L + c * L + d);
            if(x > ans) ans = x;
            x = abs(a * R * R * R  + b * R * R + c * R + d);
            if(x > ans) ans = x;
        }
        else
        {
            x = abs(a * L * L * L  + b * L * L + c * L + d);
            if(x > ans) ans = x;
            x = abs(a * R * R * R  + b * R * R + c * R + d);
            if(x > ans) ans = x;
        }
        printf("%.2lf\n", ans);
    }

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值