1023. Have Fun with Numbers (20)

题目:

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input file contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:
1234567899
Sample Output:
Yes
2469135798
注意:
1、一定要非常小心进位,特别是最高位也需要进位的时候!!!
2、由于这里的输入可能是10^20量级,所以我直接用了字符数组来计算,先将每一位数字乘以2,再判断是否需要进位,并统计0~9每个数字出现的次数是否与输入相同。

代码:
#include<iostream>
#include<string>
#include<cstring>
using namespace std;

int main()
{
	//x:input number
	//x2:double number
	char x[21],x2[21],t;
	//xdigit:appearence time if each digit from 0 to 9
	//it is more convenient to compare by using function strcmp than int[]
	char xdigit[11],x2digit[11];
	memset(xdigit, '0',sizeof (xdigit)); xdigit[10]='\0';
	strcpy(x2digit,xdigit);
	int i=0;
	cin>>x;
	while(x[i]!='\0' )
	{
		++xdigit[x[i]- '0'];//count each digit for x
		x2[i]=(x[i]- '0')*2+'0' ;//double each digit
		++i;
	}
	x2[i]= '\0';
	while(--i)
	{
		if(x2[i]-'0' >9)//
		{++x2[i-1];         x2[i]-=10;}
		++x2digit[x2[i]- '0'];//count each digit for x2 except the first digit
	}
	if(x2[0]-'0' >9)
	{ //if the first digit of x2 is more than 9,that means the length of x2 increases by 1 digit
		cout<< "No"<<endl;
		x2[0]-=10;
		cout<<1<<x2<<endl;
		return 0;
	}
	else
	{
		++x2digit[x2[0]- '0'];//don't forget the first digit!
		if(strcmp(xdigit,x2digit)==0)
			cout<< "Yes"<<endl;
		else cout<<"No" <<endl;
		cout<<x2;
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值