HDU 3535 AreYouBusy (多组背包综合)

题面

Happy New Term!
As having become a junior, xiaoA recognizes that there is not much time for her to AC problems, because there are some other things for her to do, which makes her nearly mad.
What's more, her boss tells her that for some sets of duties, she must choose at least one job to do, but for some sets of things, she can only choose at most one to do, which is meaningless to the boss. And for others, she can do of her will. We just define the things that she can choose as "jobs". A job takes time , and gives xiaoA some points of happiness (which means that she is always willing to do the jobs).So can you choose the best sets of them to give her the maximum points of happiness and also to be a good junior(which means that she should follow the boss's advice)?

Input

There are several test cases, each test case begins with two integers n and T (0<=n,T<=100) , n sets of jobs for you to choose and T minutes for her to do them. Follows are n sets of description, each of which starts with two integers m and s (0<m<=100), there are m jobs in this set , and the set type is s, (0 stands for the sets that should choose at least 1 job to do, 1 for the sets that should choose at most 1 , and 2 for the one you can choose freely).then m pairs of integers ci,gi follows (0<=ci,gi<=100), means the ith job cost ci minutes to finish and gi points of happiness can be gained by finishing it. One job can be done only once.

Output

One line for each test case contains the maximum points of happiness we can choose from all jobs .if she can’t finish what her boss want, just output -1 .

Sample Input

3 3
2 1
2 5
3 8
2 0
1 0
2 1
3 2
4 3
2 1
1 1

3 4
2 1
2 5
3 8
2 0
1 1
2 8
3 2
4 4
2 1
1 1

1 1
1 0
2 1

5 3
2 0
1 0
2 1
2 0
2 2
1 1
2 0
3 2
2 1
2 1
1 5
2 8
3 2
3 8
4 9
5 10

Sample Output

5
13
-1
-1

题目链接

HDU_3535

参考链接

hdu3535 (分组背包,最少选一 + 最多选一 + 随意) author:沙漠孤舟

题目简述

对于每组样例有n个工作集合,给出时间为T,问最大的happiness

对于每个工作集合,其中有m个工作,类型为s

s==0,至少选一个

s==1,至多选一个

x==2随意选

分析

dp[i][j]表示,到第i个工作集合,总时间为j,能得到的最大的开心值。

程序

#include<stdio.h>
#include<string.h>
#include<iostream>
#define maxn 105
using namespace std;
int dp[maxn][maxn];

int main()
{
    int n,T;
    while(scanf("%d%d",&n,&T)!=EOF)
    {
        for(int i=0;i<=T;i++)
            dp[0][i]=0;
        for(int i=1;i<=n;i++)
        {
            int m,s;
            scanf("%d%d",&m,&s);
            if(s==0)
                memset(dp[i],-1,sizeof(dp[i]));
            else
            {
                for(int j=0;j<=T;j++)
                    dp[i][j]=dp[i-1][j];
            }
            while(m--)
            {
                int c,g;
                scanf("%d%d",&c,&g);
                for(int j=T;j>=c;j--)
                {
                    if(s==0)
                    {
                        if(dp[i][j-c]!=-1)
                            dp[i][j]=max(dp[i][j],dp[i][j-c]+g);
                        if(dp[i-1][j-c]!=-1)
                            dp[i][j]=max(dp[i][j],dp[i-1][j-c]+g);
                    }
                    else if(s==1)
                    {
                        if(dp[i-1][j-c]!=-1)
                            dp[i][j]=max(dp[i][j],dp[i-1][j-c]+g);
                        if(dp[i-1][j]!=-1)
                            dp[i][j]=max(dp[i][j],dp[i-1][j]);
                    }
                    else
                    {
                        if(dp[i-1][j]!=-1)
                            dp[i][j]=max(dp[i][j],dp[i-1][j]);
                        if(dp[i][j-c]!=-1)
                            dp[i][j]=max(dp[i][j],dp[i][j-c]+g);
                        if(dp[i-1][j-c]!=-1)
                            dp[i][j]=max(dp[i][j],dp[i-1][j-c]+g);
                    }
                }
            }
        }
        printf("%d\n",dp[n][T]);
    }
    return 0;
}

各类背包问题的复习……

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值