ZJM 与准备霍格沃兹【字符串】【哈希】

问题描述

ZJM 为了准备霍格沃兹的期末考试,决心背魔咒词典,一举拿下咒语翻译题
题库格式:[魔咒] 对应功能
背完题库后,ZJM 开始刷题,现共有 N 道题,每道题给出一个字符串,可能是 [魔咒],也可能是对应功能
ZJM 需要识别这个题目给出的是 [魔咒] 还是对应功能,并写出转换的结果,如果在魔咒词典里找不到,输出 “what?”

Input

首先列出魔咒词典中不超过100000条不同的咒语,每条格式为:

[魔咒] 对应功能

其中“魔咒”和“对应功能”分别为长度不超过20和80的字符串,字符串中保证不包含字符“[”和“]”,且“]”和后面的字符串之间有且仅有一个空格。魔咒词典最后一行以“@END@”结束,这一行不属于词典中的词条。
词典之后的一行包含正整数N(<=1000),随后是N个测试用例。每个测试用例占一行,或者给出“[魔咒]”,或者给出“对应功能”。

Output

每个测试用例的输出占一行,输出魔咒对应的功能,或者功能对应的魔咒。如果在词典中查不到,就输出“what?”

Sample Input

[expelliarmus] the disarming charm
[rictusempra] send a jet of silver light to hit the enemy
[tarantallegra] control the movement of one's legs
[serpensortia] shoot a snake out of the end of one's wand
[lumos] light the wand
[obliviate] the memory charm
[expecto patronum] send a Patronus to the dementors
[accio] the summoning charm
@END@
4
[lumos]
the summoning charm
[arha]
take me to the sky

Sample Output

light the wand
accio
what?
what?

问题分析

这是一个字符串之间的对应问题,可以哈希。
采用字符串哈希Bkdr Hash算法,选取seed,字符串的字符乘以seed的字符位置次方做累加求得其哈希值。
seed常取7,17,131.
哈希值一般会比较大,可以mod一个大质数也可以采用unsigned让他自然溢出。
不过哈希有时候会比较看数据,不幸运会被卡。

#include<stdio.h>
#include<string>
#include<string.h>
#include<map> 
#include<iostream>
using namespace std;
int seed=17;
map<unsigned,int> mp;
string s1[100010],s2[100010];
int tot=0;
unsigned int _hash(string str){
	int l=str.length();
	unsigned int h=0;
    for (int i=0; i<l; i++)
        h+=h*seed+(unsigned)(str[i]);
    return h;
}
int main(){
	char s[200];
	int n;
	gets(s);
	while(s[0]=='['){
		string ss1,ss2;
		int l=strlen(s);
		for (int i=1; i<l; i++){
        	if(s[i]==']'){
            	ss1=ss2;
           		ss2.clear();
            	i++;//空格 
        	}
        	else ss2+=s[i];
    	}
		mp[_hash(ss1)]=tot;
		s1[tot]=ss2;
		mp[_hash(ss2)]=tot;
		s2[tot]=ss1;
		tot++;
		gets(s);
	}
	scanf("%d\n",&n);
	for(int i=0;i<n;i++){
		gets(s);
		string ss;
		int l=strlen(s);
		if(s[0]=='[')
			for(int i=1;i<l-1;i++)
				ss+=s[i];
		else for(int i=0;i<l;i++)
				ss+=s[i];
		int p=mp[_hash(ss)];
		if(p==0)
			printf("what?\n");
		else if(s[0]=='[')cout<<s1[p]<<endl;
			else cout<<s2[p]<<endl;
	}
	
	return 0;
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值