POJ 1502 MPI Maelstrom 【最短路(迪杰斯特拉)】

Description

BIT has recently taken delivery of their new supercomputer, a 32 processor Apollo Odyssey distributed shared memory machine with a hierarchical communication subsystem. Valentine McKee's research advisor, Jack Swigert, has asked her to benchmark the new system.
``Since the Apollo is a distributed shared memory machine, memory access and communication times are not uniform,'' Valentine told Swigert. ``Communication is fast between processors that share the same memory subsystem, but it is slower between processors that are not on the same subsystem. Communication between the Apollo and machines in our lab is slower yet.''

``How is Apollo's port of the Message Passing Interface (MPI) working out?'' Swigert asked.

``Not so well,'' Valentine replied. ``To do a broadcast of a message from one processor to all the other n-1 processors, they just do a sequence of n-1 sends. That really serializes things and kills the performance.''

``Is there anything you can do to fix that?''

``Yes,'' smiled Valentine. ``There is. Once the first processor has sent the message to another, those two can then send messages to two other hosts at the same time. Then there will be four hosts that can send, and so on.''

``Ah, so you can do the broadcast as a binary tree!''

``Not really a binary tree -- there are some particular features of our network that we should exploit. The interface cards we have allow each processor to simultaneously send messages to any number of the other processors connected to it. However, the messages don't necessarily arrive at the destinations at the same time -- there is a communication cost involved. In general, we need to take into account the communication costs for each link in our network topologies and plan accordingly to minimize the total time required to do a broadcast.''

Input

The input will describe the topology of a network connecting n processors. The first line of the input will be n, the number of processors, such that 1 <= n <= 100.

The rest of the input defines an adjacency matrix, A. The adjacency matrix is square and of size n x n. Each of its entries will be either an integer or the character x. The value of A(i,j) indicates the expense of sending a message directly from node i to node j. A value of x for A(i,j) indicates that a message cannot be sent directly from node i to node j.

Note that for a node to send a message to itself does not require network communication, so A(i,i) = 0 for 1 <= i <= n. Also, you may assume that the network is undirected (messages can go in either direction with equal overhead), so that A(i,j) = A(j,i). Thus only the entries on the (strictly) lower triangular portion of A will be supplied.

The input to your program will be the lower triangular section of A. That is, the second line of input will contain one entry, A(2,1). The next line will contain two entries, A(3,1) and A(3,2), and so on.

Output

Your program should output the minimum communication time required to broadcast a message from the first processor to all the other processors.

Sample Input

5
50
30 5
100 20 50
10 x x 10

Sample Output

35


题目大意:(来自lmhacm的博客【博客地址:http://blog.csdn.net/lmhacm?viewmode=contents,欢迎去给他增加人气..】,虽然是他手打的描述,很辛苦,但当时他懒得读题,是我给他讲的题意,所以就拿过来用了)

  题意是说一个线路中进行信息传递,从一个处理器开始向外同时发出信号,问最短需要多少时间可以让所有处理器收到信号。这道题说是最短,其实是求走过这些路的所有点中最长的一个,因为是同时发出的,所以最长的这一条线路接收到就可以认定为全部收到了。而判断是否为最长的线路中最短的一条,就可以用求最短路的方法来求出,因为要对所有点进行一下标记,所以这里使用Dijkstra算法

    在看代码的时候还注意到一个新的用法,因为题目的输入是通过矩阵的斜三角输入的,如果两点之间没有路径就输入一个'x',所以这里需要区分开输入的是数字还是字母,因此学到了一个工具叫做atoi()函数,他的作用是把字符串变成int型数字,atoi() 函数会扫描参数 str 字符串,跳过前面的空白字符(例如空格,tab缩进等),直到遇上数字或正负符号才开始做转换,而再遇到非数字或字符串结束时('\0')才结束转换,并将结果返回。所以这里输入直接用char输入,如果是数字就可以直接改正,而不用像我之前那样一位一位代换了。

AC代码:

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
#include <cmath>
#define INF 0x3f3f3f3f
const int maxn = 105;
using namespace std;
bool vis[maxn];
int adj[maxn][maxn],dis[maxn];
int n,tem;
char ch[15];
int dijkstra()
{
    int minx;
    memset(vis, 0, sizeof(vis));
    for(int i = 1; i <= n; i++)
        dis[i] = adj[1][i];
    for(int i=1; i <= n; i++)
    {
        minx = INF, tem = 0;
        for(int j = 1; j <= n; j++)
        {
            if(!vis[j] && dis[j] < minx)
            {
                minx = dis[j];
                tem = j;
            }
        }
        vis[tem] = 1;
        for(int j = 1; j <= n; j++)
        {
            if(!vis[j] && dis[tem] + adj[tem][j] < dis[j])
                dis[j] = adj[tem][j] + dis[tem];
        }
    }
    return minx;
}
int main()
{
    while(~scanf("%d",&n))
    {
        for(int i = 2; i <= n; ++i)
            for(int j = 1; j <= i-1; j++)
            {
                scanf("%s",ch);
                if(ch[0] == 'x') adj[i][j] = adj[j][i] = INF;
                else  adj[i][j] = adj[j][i] = atoi(ch);
            }    //初始化
        for(int i = 1; i <= n; ++i)  adj[i][i] = 0;
        printf("%d\n",dijkstra());
    }
    return 0;
}


PS:记得要读准题目要求,比如x不是X(看似很ZZ的错误,我在这上面卡了好久)。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值