HUSTOJ 进阶题组1 问题 I Queuing

题目描述

        Queues and Priority Queues are data structures which are known to most computer scientists. The Queue occurs often in our daily life. There are many people lined up at the lunch time.
       Now we define that ‘f’ is short for female and ‘m’ is short for male. If the queue’s length is L, then there are 2L numbers of queues. For example, if L = 2, then they are ff, mm, fm, mf . If there exists a subqueue as fmf or fff, we call it O-queue else it is a E-queue.
Your task is to calculate the number of E-queues mod M with length L by writing a program.

输入

Input a length L (0 <= L <= 10 6) and M.

输出

Output K mod M(1 <= M <= 30) where K is the number of E-queues with length L.

样例输入 Copy
3 8
4 7
4 8
样例输出 Copy
6
2
1
#include<iostream>
#include<cstring>
using namespace std;

struct Matrix {
	long long value[10][10];
}A,arr;
int N, mod;
int f[5] = { 0,2,4,6,9 };

//重载矩阵的乘法*
Matrix operator*(Matrix a, Matrix b) {
	Matrix temp;
	memset(temp.value, 0, sizeof(temp));
	for (int i = 0; i < 4; i++)
		for (int j = 0; j < 4; j++)
			for (int k = 0; k < 4; k++)
				temp.value[i][j] = (temp.value[i][j] + (a.value[i][k] * b.value[k][j]) % mod) % mod;
	return temp;
}

Matrix fast_power(Matrix a, int b) {
	Matrix res;
	memset(res.value, 0, sizeof(res.value));
	for (int i = 0; i < 4; i++)res.value[i][i] = 1;
	while (b>0) {
		if (b & 1)res = res * a;
		a = a * a;
		b >>= 1;
	}
	return res;
}

void init() {
	memset(arr.value, 0, sizeof(arr.value));
	arr.value[0][0] = f[4];
	arr.value[0][1] = f[3];
	arr.value[0][2] = f[2];
	arr.value[0][3] = f[1];
	memset(A.value, 0, sizeof(A.value));
	A.value[0][0] = A.value[0][1] = A.value[1][2] = A.value[2][0] = A.value[2][3] = A.value[3][0] = 1;
}

int main() 
{
	while (scanf("%d %d", &N, &mod) != EOF) {
		if (N <= 4) {
			printf("%d\n", f[N] % mod);
			continue;
		}
		init();
		Matrix ans_A = fast_power(A, N - 4);
		Matrix ans = arr * ans_A;
		printf("%lld\n", ans.value[0][0]);
	}
	return 0;
}

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值