F - Binary Number

F - Binary Number
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

For 2 non-negative integers x and y, f(x, y) is defined as the number of different bits in the binary format of x and y. For example, f(2, 3)=1,f(0, 3)=2, f(5, 10)=4. Now given 2 sets of non-negative integers A and B, for each integer b in B, you should find an integer a in A such that f(a, b) is minimized. If there are more than one such integer in set A, choose the smallest one.
 

Input

The first line of the input is an integer T (0 < T ≤ 100), indicating the number of test cases. The first line of each test case contains 2 positive integers m and n (0 < m, n ≤ 100), indicating the numbers of integers of the 2 sets A and B, respectively. Then follow (m + n) lines, each of which contains a non-negative integers no larger than 1000000. The first m lines are the integers in set A and the other n lines are the integers in set B.
 

Output

For each test case you should output n lines, each of which contains the result for each query in a single line.
 

Sample Input

     
     
2 2 5 1 2 1 2 3 4 5 5 2 1000000 9999 1423 3421 0 13245 353
 

Sample Output

     
     
1 2 1 1 1 9999 0


水题,给了你两个容器A,B,对于B中的每个数找出A中的哪个数能够让F(a,b)最小,如果相等则取A的较小值


F(a,b)为两个数的二进制数在同一个位置值不同的数量。


思路,直接将两个数异或,然后求得到的数有几个1就是F(a,b)的数量,知道怎么求之后暴力扫一遍即可


#include"iostream"
#include"cstring"
#include"cstdio"
#include"algorithm"

#define INF 0x7f7f7f7f

using namespace std;

int N,M;
int A[105],B[105];

int compare(int a,int b)
{
    int c = a^b;
    int cnt = 0;
    while(c > 0)
    {
        if(c&1 == 1) cnt ++;
        c >>= 1;
    }
    return cnt;
}

int main(void)
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&M,&N);
        for(int i = 0;i < M;i++) scanf("%d",&A[i]);
        for(int i = 0;i < N;i++) scanf("%d",&B[i]);

        for(int i = 0;i < N;i++)
        {
            int minn = INF;
            int ans = -1;
            for(int j = 0;j < M;j++)
            {
                int num = compare(B[i],A[j]);
                if(minn > num || (minn == num && A[j] < ans))
                {
                    minn = num;
                    ans = A[j];
                }
            }
            printf("%d\n",ans);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值