HDU 1396 Counting Triangles

Problem Description
Given an equilateral triangle with n the length of its side, program to count how many triangles in it. HDU <wbr>1396 <wbr>Counting <wbr>Triangles
Input
The length n (n <= 500) of the equilateral triangle's side, one per line.

process to the end of the file
 
Output
The number of triangles in the equilateral triangle, one per line.
 
Sample Input
1 2 3
 
Sample Output
1 5 13
做这个题目要了解,有关数三角形的公式,本质就是一题简单的数学题。
 
AC代码:
#include<iostream>
using namespace std;
int main()
{
 __int64 a[501]={0,1};
 int i,x,y;
 for(i=2,x=y=0;i<=500;i++)
 { 
        if(i%2==0){x++;}
        else {y++;}
  a[i]=a[i-1]+i*i-x*y;
 }
 int n;
 while(scanf("%d",&n)!=EOF)
 {printf("%I64d\n",a[n]);}
 return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值