PAT (Advanced Level)1059 Prime Factors (25分)

Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p​1​​​k​1​​​​×p​2​​​k​2​​​​×⋯×p​m​​​k​m​​​​.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range of long int.

Output Specification:

Factor N in the format N = p​1​​^k​1​​*p​2​​^k​2​​**p​m​​^k​m​​, where p​i​​'s are prime factors of N in increasing order, and the exponent k​i​​ is the number of p​i​​ -- hence when there is only one p​i​​, k​i​​ is 1 and must NOT be printed out.

Sample Input:

97532468

Sample Output:

97532468=2^2*11*17*101*1291

代码

#include<stdio.h>
#include<math.h>

const int maxn=100010;
int prime[maxn],num=0;
bool p[maxn]={0};

struct factor{
	int x,cnt;
	factor(){}
	factor(int _x,int _cnt){
		x=_x;
		cnt=_cnt;
	}
}fac[10];

bool isprime(int n){
	if(n==1) return false;
	for(int i=2;i<(int)sqrt(1.0*n);i++){
		if(n%i==0)
			return false;
	}
	return true;
}

void find_prime(){
	for(int i=2;i<maxn;i++)
	if(p[i]==false){	//如果i没有被筛掉 
		prime[num++]=i;
		for(int j=i+i;j<maxn;j+=i){ 
			p[j]=true;	//筛掉j 
		}
	} 
}

int main(){
	long int n;
	int count=0;
	find_prime();
	scanf("%ld",&n);
	if(n==1){		//n=1的特判 
		printf("1=1");
		return 0;
	}
	int sqt=(int)sqrt(1.0*n);
	printf("%ld=",n);
	for(int i=0;prime[i]<=sqt;i++){	//终止条件是<=,不能漏掉= 
		if(n%prime[i]==0){
			fac[count]=factor(prime[i],0);
			while(n%prime[i]==0){
				fac[count].cnt++;
				n/=prime[i];
			}
			count++;
		}
	}
	if(n!=1){
		fac[count++]=factor(n,1);
	}
	for(int i=0;i<count;i++){
		printf("%d",fac[i].x);
		if(fac[i].cnt!=1)
			printf("^%d",fac[i].cnt);
		if(i!=count-1)
			printf("*");
	}
	return 0;
} 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值