PAT (Advanced Level) 1059 Prime Factors (25 分)

1059 Prime Factors (25 分)

Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p​1​​​k​1​​​​×p​2​​​k​2​​​​×⋯×p​m​​​k​m​​​​.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range of long int.

Output Specification:

Factor N in the format N = p​1​​k​1​​*p​2​​k​2​​*…*p​m​​^k​m​​, where p​i​​’s are prime factors of N in increasing order, and the exponent k​i​​ is the number of p​i​​ – hence when there is only one p​i​​, k​i​​ is 1 and must NOT be printed out.

Sample Input:

97532468

Sample Output:

97532468=2^2*11*17*101*1291

Code:

#include <iostream>
#include <vector>
#include <cmath>
using namespace std;

typedef long long LL;

struct Factor
{
	int x, exp = 0;
	Factor(int xx, int e) :x(xx), exp(e) {}
	Factor() {};
};

vector<int> getPrimeTable(int maxn)
{
	vector<int> prime(1, 0);
	vector<bool> p(maxn, false);
	for (int i = 2; i < maxn; i++)
	{
		if (!p[i])
		{
			prime.push_back(i);
			for (int j = i * 2; j < maxn / 2; j += i)
				p[j] = true;
		}
	}
	return prime;
}

int main()
{
	LL n;
	cin >> n;
	if (n == 1)
	{
		cout << "1=1" << endl;
		return 0;
	}
	cout << n << "=";
	vector<Factor> factors;
	vector<int> prime = getPrimeTable(10001);
	LL sqr = sqrt(n * 1.0);
	for (int i = 1; i < prime.size() && prime[i] <= sqr; i++)
	{
		if (n % prime[i] == 0)
		{
			Factor f(prime[i], 0);
			while (n % prime[i] == 0)
			{
				n /= prime[i];
				f.exp++;
			}
			factors.push_back(f);
			if (n == 1) break;
		}
	}
	if (n != 1)
		factors.push_back(Factor(n, 1));
	for (int i = 0; i < factors.size(); i++)
	{
		cout << factors[i].x;
		if (factors[i].exp > 1)
			cout << '^' << factors[i].exp;
		cout << (i == factors.size() - 1 ? '\n' : '*');
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值