PAT (Advanced Level) 1059. Prime Factors (25) 求所有质因子

Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p1^k1* p2^k2 *…*pm^km.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range of long int.

Output Specification:

Factor N in the format N = p1^k1 * p2^k2 *…*pm^km, where pi's are prime factors of N in increasing order, and the exponent ki is the number of pi -- hence when there is only one pi, ki is 1 and must NOT be printed out.

Sample Input:
97532468
Sample Output:
97532468=2^2*11*17*101*1291
求出所有质因子存到结果数组,输出控制。
/*2015.7.27cyq*/
#include <iostream>
#include <vector>
using namespace std;

bool isprime(int n){
	if(n<=1)
		return false;
	if(n==2||n==3)
		return true;
	for(int i=2;i*i<=n;i++)
		if(n%i==0)
			return false;
	return true;
}
int main(){
	long N;
	cin>>N;
	if(N==1){
		cout<<"1=1";
		return 0;
	}
	vector<int> result;//结果数组,存储所有质因子
	long tmp=N;
	while(tmp!=1){
		for(int i=2;i<=tmp;i++){
			if(isprime(i)&&(tmp%i==0)){
				result.push_back(i);
				tmp/=i;
				break;
			}
		}
	}

	cout<<N<<"=";
	auto it=result.begin();
	cout<<*it;
	long pre=*it;
	it++;
	int count=1;
	while(it!=result.end()){
		while(it<result.end()&&*it==pre){
			count++;
			it++;
		}
		//it指向一个新的数或result.end()
		if(count>1){
			cout<<"^"<<count;
			count=1;
		}else{
			cout<<"*"<<*it;
			pre=*it;
			it++;
		}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值