Family Property (并查集,麻烦

This time, you are supposed to help us collect the data for family-owned property. Given each person's family members, and the estate(房产)info under his/her own name, we need to know the size of each family, and the average area and number of sets of their real estate.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤1000). Then N lines follow, each gives the infomation of a person who owns estate in the format:

ID Father Mother k Child​1​​⋯Child​k​​ M​estate​​ Area

where ID is a unique 4-digit identification number for each person; Father and Mother are the ID's of this person's parents (if a parent has passed away, -1 will be given instead); k (0≤k≤5) is the number of children of this person; Child​i​​'s are the ID's of his/her children; M​estate​​ is the total number of sets of the real estate under his/her name; and Area is the total area of his/her estate.

Output Specification:

For each case, first print in a line the number of families (all the people that are related directly or indirectly are considered in the same family). Then output the family info in the format:

ID M AVG​sets​​ AVG​area​​

where ID is the smallest ID in the family; M is the total number of family members; AVG​sets​​ is the average number of sets of their real estate; and AVG​area​​ is the average area. The average numbers must be accurate up to 3 decimal places. The families must be given in descending order of their average areas, and in ascending order of the ID's if there is a tie.

Sample Input:

10
6666 5551 5552 1 7777 1 100
1234 5678 9012 1 0002 2 300
8888 -1 -1 0 1 1000
2468 0001 0004 1 2222 1 500
7777 6666 -1 0 2 300
3721 -1 -1 1 2333 2 150
9012 -1 -1 3 1236 1235 1234 1 100
1235 5678 9012 0 1 50
2222 1236 2468 2 6661 6662 1 300
2333 -1 3721 3 6661 6662 6663 1 100

Sample Output:

3
8888 1 1.000 1000.000
0001 15 0.600 100.000
5551 4 0.750 100.000
#include<bits/stdc++.h>
#include<set>
#include<vector>
#include<map>
#include<queue>
#include<string>
#include<stack>
using namespace std;
int par[10005];
int house[10005],area[10005],p[10005];
int find(int x) {

	while(x!=par[x])
		x=par[x];

	return x;
}
void merge(int a,int b) {
	int A=find(a);
	int B=find(b);

	if(A!=B) {
		if(A>B)
		swap(A,B);
		par[B]=A;
	}
}
struct node {
	int id;
	int hn;
	double avgh;
	double avga;
};

bool cmp(node a,node b)
{
	if(a.avga==b.avga)return a.id<b.id;
	return a.avga>b.avga;
}
int main() {
	map<int,int>vis;
	map<int,int>idd;
	for(int i=0; i<10005; i++)
		par[i]=i;

	int n;
	cin>>n;
	int cnt=0;
	vector<int>peo;
	while(n--) {
		int id,p1,p2,m,pn=0;
		cin>>id>>p1>>p2>>m;
		if(p1!=-1)pn++;
		if(p2!=-1)pn++;

		if(!vis[id]) {
			peo.push_back(id);
			vis[id]=1;
		}
		if(!vis[p1]&&p1!=-1) {
			peo.push_back(p1);
			vis[p1]=1;
		}
		if(!vis[p2]&&p2!=-1) {
			peo.push_back(p2);
			vis[p2]=1;
		}
		if(p1!=-1)merge(id,p1);
		if(p2!=-1)merge(id,p2);

		for(int i=0; i<m; i++) {
			int c;
			cin>>c;
			if(!vis[c]) {
				peo.push_back(c);
				vis[c]=1;
			}
			merge(id,c);
		}
		
		int hn,ha;
		cin>>hn>>ha;
		house[id]=hn;
		area[id]=ha;
	}
	
	map<int,int>vis1;
	vector<int>ANS;
	for(int i=0; i<peo.size(); i++) {
		int minn=find(peo[i]);
		if(!vis1[minn])
		{
			vis1[minn]=1;
			ANS.push_back(minn); 
		}
		if(peo[i]==find(peo[i]))continue;
		house[minn]+=house[peo[i]];
		area[minn]+=area[peo[i]];
		p[minn]++;
	}
	cout<<ANS.size()<<endl;
	
	vector<node>aans;
	for(int i=ANS.size()-1;i>=0;i--)
	{
		int iddd=ANS[i];
		p[iddd]++;	
		double nn=(double)house[iddd]/p[iddd];
		double aa=(double)area[iddd]/p[iddd];
		
		node pp;
		pp.avga=aa;
		pp.avgh=nn;
		pp.hn=p[iddd];
		pp.id=iddd;
		
		aans.push_back(pp);
	}
	sort(aans.begin(),aans.end(),cmp);
	for(int i=0;i<aans.size();i++)
	printf("%04d %d %.3lf %.3lf\n",aans[i].id,aans[i].hn,aans[i].avgh,aans[i].avga);
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值