POJ1724 ROADS

点击这里查看原题

题目:

Description

N cities named with numbers 1 … N are connected with one-way roads. Each road has two parameters associated with it : the road length and the toll that needs to be paid for the road (expressed in the number of coins).
Bob and Alice used to live in the city 1. After noticing that Alice was cheating in the card game they liked to play, Bob broke up with her and decided to move away - to the city N. He wants to get there as quickly as possible, but he is short on cash.

We want to help Bob to find the shortest path from the city 1 to the city N that he can afford with the amount of money he has.
Input

The first line of the input contains the integer K, 0 <= K <= 10000, maximum number of coins that Bob can spend on his way.
The second line contains the integer N, 2 <= N <= 100, the total number of cities.

The third line contains the integer R, 1 <= R <= 10000, the total number of roads.

Each of the following R lines describes one road by specifying integers S, D, L and T separated by single blank characters :
S is the source city, 1 <= S <= N
D is the destination city, 1 <= D <= N
L is the road length, 1 <= L <= 100
T is the toll (expressed in the number of coins), 0 <= T <=100

Notice that different roads may have the same source and destination cities.
Output

The first and the only line of the output should contain the total length of the shortest path from the city 1 to the city N whose total toll is less than or equal K coins.
If such path does not exist, only number -1 should be written to the output.
Sample Input

5
6
7
1 2 2 3
2 4 3 3
3 4 2 4
1 3 4 1
4 6 2 1
3 5 2 0
5 4 3 2
Sample Output

11
Source

CEOI 1998

解答:


/* 
//POJ1724
//ROADS 深度优先 
#include<iostream>
#include<cstring>
#include<vector>
using namespace std;
int K,N,R;//N个城市 
struct Road{
    int d,L,t;
}; 
//用邻接表存放整条路的信息
vector< vector<Road> >G(110);

int minLen;//存储目前找过的最佳的路径长度
int totalLen;//已经探索的路径已经走了多长
int totalCost;//长在走的路已经花了多少钱
int visited[110];//标志数组,表示一个城市是否已经走过 

void dfs(int s){
    if(s==N){
        minLen=min(minLen,totalLen);
        return;
    }
    for(int i=0;i<G[s].size();++i){
        Road r=G[s][i];
        if(totalCost+r.t>K)
            continue;
        if(!visited[r.d]){
            totalLen+=r.L;
            totalCost+=r.t;
            visited[r.d]=1;
            dfs(r.d);
            visited[r.d]=0;
            totalLen-=r.L;
            totalCost-=r.t;
        }
    }
}


int main(){
    cin>>K>>N>>R;
    for(int i=0;i<R;i++){
        int s;
        Road r;
        cin>>s>>r.d>>r.L>>r.t;//起点s,终点d,边的长的L,边的过路费t
        if(s!=r.d){
            G[s].push_back(r);
        } 
    }
    //初始化 
    memset(visited,0,sizeof(visited));
    totalLen=0;
    minLen=1<<30;
    totalCost=0;
    visited[1]=1;
    dfs(1);
    if(minLen<(1<<30)){
        cout<<minLen<<endl;
    }else 
        cout<<"-1"<<endl;
    return 0;
} //超时

*/ 
/* 
 //POJ1724
//ROADS 深度优先 
#include<iostream>
#include<cstring>
#include<vector>
using namespace std;
int K,N,R;//N个城市 
struct Road{
    int d,L,t;
}; 
//用邻接表存放整条路的信息
vector< vector<Road> >G(110);

int minLen;//存储目前找过的最佳的路径长度
int totalLen;//已经探索的路径已经走了多长
int totalCost;//长在走的路已经花了多少钱
int visited[110];//标志数组,表示一个城市是否已经走过 

void dfs(int s){
    if(s==N){
        minLen=min(minLen,totalLen);
        return;
    }
    for(int i=0;i<G[s].size();++i){
        Road r=G[s][i];
        if(totalCost+r.t>K)
            continue;
        if(!visited[r.d]){
            if(totalLen+r.L>=minLen){//最优性剪枝: 
                continue;//(1)如果当前已经找到的最优路径长度为L,那么再继续搜索的过程中,总长度已经大于等于L的走法,就可以直接放弃,不用坚持到底 
            } /很强的剪枝,效果拔群 
            totalLen+=r.L;
            totalCost+=r.t;
            visited[r.d]=1;
            dfs(r.d);
            visited[r.d]=0;
            totalLen-=r.L;
            totalCost-=r.t;
        }
    }
}


int main(){
    cin>>K>>N>>R;
    for(int i=0;i<R;i++){
        int s;
        Road r;
        cin>>s>>r.d>>r.L>>r.t;//起点s,终点d,边的长的L,边的过路费t
        if(s!=r.d){
            G[s].push_back(r);
        } 
    }
    //初始化 
    memset(visited,0,sizeof(visited));
    totalLen=0;
    minLen=1<<30;
    totalCost=0;
    visited[1]=1;
    dfs(1);
    if(minLen<(1<<30)){
        cout<<minLen<<endl;
    }else 
        cout<<"-1"<<endl;
    return 0;
} //可惜还是超时 
*/ 



 //POJ1724
//ROADS 深度优先 
#include<iostream>
#include<cstring>
#include<vector>
using namespace std;
int K,N,R;//N个城市 
struct Road{
    int d,L,t;
}; 
//用邻接表存放整条路的信息
vector< vector<Road> >G(110);
int minL[110][10010];///////////////////////////////////
int minLen;//存储目前找过的最佳的路径长度
int totalLen;//已经探索的路径已经走了多长
int totalCost;//长在走的路已经花了多少钱
int visited[110];//标志数组,表示一个城市是否已经走过 

//用mid[k][m]表示:走到城市k时总过路费为m的条件下,最优路径的长度。若在后续的搜索中,在此走到k时,如果总路费恰好为m,且此时的路径长度已经超过mid[k][m],则不必再走下去了。 

void dfs(int s){
    if(s==N){
        minLen=min(minLen,totalLen);
        return;
    }
    for(int i=0;i<G[s].size();++i){
        Road r=G[s][i];
        if(totalCost+r.t>K)
            continue;
        if(!visited[r.d]){
            if(totalLen+r.L>=minLen){
                continue;
            }

            /////////////////////////////////////////////////////////////可行性剪枝: 
            if(totalLen+r.L>=minL[r.d][totalCost+r.t])///////////////////啥都不说了: 
                continue;/////////////////////////////////////////////////加速超快!! 
            minL[r.d][totalCost+r.t]=totalLen+r.L;////////////////////////


            totalLen+=r.L;
            totalCost+=r.t;
            visited[r.d]=1;
            dfs(r.d);
            visited[r.d]=0;
            totalLen-=r.L;
            totalCost-=r.t;
        }
    }
}


int main(){
    cin>>K>>N>>R;
    for(int i=0;i<R;i++){
        int s;
        Road r;
        cin>>s>>r.d>>r.L>>r.t;//起点s,终点d,边的长的L,边的过路费t
        if(s!=r.d){
            G[s].push_back(r);
        } 
    }
    //初始化 
    memset(visited,0,sizeof(visited));
    totalLen=0;
    minLen=1<<30;
    totalCost=0;
    visited[1]=1;//////////////////////////////////
    for(int i=0;i<110;i++){/////////////////////////
        for(int j=0;j<10010;j++){/////////////////
            minL[i][j]=1<<30;///////////////////////
        }//////////////////////////////////////////
    }////////////////////////////////////////////////
    dfs(1);
    if(minLen<(1<<30)){
        cout<<minLen<<endl;
    }else 
        cout<<"-1"<<endl;
    return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值