POJ1724 ROADS

点击这里查看原题

题目:

Description

N cities named with numbers 1 … N are connected with one-way roads. Each road has two parameters associated with it : the road length and the toll that needs to be paid for the road (expressed in the number of coins).
Bob and Alice used to live in the city 1. After noticing that Alice was cheating in the card game they liked to play, Bob broke up with her and decided to move away - to the city N. He wants to get there as quickly as possible, but he is short on cash.

We want to help Bob to find the shortest path from the city 1 to the city N that he can afford with the amount of money he has.
Input

The first line of the input contains the integer K, 0 <= K <= 10000, maximum number of coins that Bob can spend on his way.
The second line contains the integer N, 2 <= N <= 100, the total number of cities.

The third line contains the integer R, 1 <= R <= 10000, the total number of roads.

Each of the following R lines describes one road by specifying integers S, D, L and T separated by single blank characters :
S is the source city, 1 <= S <= N
D is the destination city, 1 <= D <= N
L is the road length, 1 <= L <= 100
T is the toll (expressed in the number of coins), 0 <= T <=100

Notice that different roads may have the same source and destination cities.
Output

The first and the only line of the output should contain the total length of the shortest path from the city 1 to the city N whose total toll is less than or equal K coins.
If such path does not exist, only number -1 should be written to the output.
Sample Input

5
6
7
1 2 2 3
2 4 3 3
3 4 2 4
1 3 4 1
4 6 2 1
3 5 2 0
5 4 3 2
Sample Output

11
Source

CEOI 1998

解答:


/* 
//POJ1724
//ROADS 深度优先 
#include<iostream>
#include<cstring>
#include<vector>
using namespace std;
int K,N,R;//N个城市 
struct Road{
    int d,L,t;
}; 
//用邻接表存放整条路的信息
vector< vector<Road> >G(110);

int minLen;//存储目前找过的最佳的路径长度
int totalLen;//已经探索的路径已经走了多长
int totalCost;//长在走的路已经花了多少钱
int visited[110];//标志数组,表示一个城市是否已经走过 

void dfs(int s){
    if(s==N){
        minLen=min(minLen,totalLen);
        return;
    }
    for(int i=0;i<G[s].size();++i){
        Road r=G[s][i];
        if(totalCost+r.t>K)
            continue;
        if(!visited[r.d]){
            totalLen+=r.L;
            totalCost+=r.t;
            visited[r.d]=1;
            dfs(r.d);
            visited[r.d]=0;
            totalLen-=r.L;
            totalCost-=r.t;
        }
    }
}


int main(){
    cin>>K>>N>>R;
    for(int i=0;i<R;i++){
        int s;
        Road r;
        cin>>s>>r.d>>r.L>>r.t;//起点s,终点d,边的长的L,边的过路费t
        if(s!=r.d){
            G[s].push_back(r);
        } 
    }
    //初始化 
    memset(visited,0,sizeof(visited));
    totalLen=0;
    minLen=1<<30;
    totalCost=0;
    visited[1]=1;
    dfs(1);
    if(minLen<(1<<30)){
        cout<<minLen<<endl;
    }else 
        cout<<"-1"<<endl;
    return 0;
} //超时

*/ 
/* 
 //POJ1724
//ROADS 深度优先 
#include<iostream>
#include<cstring>
#include<vector>
using namespace std;
int K,N,R;//N个城市 
struct Road{
    int d,L,t;
}; 
//用邻接表存放整条路的信息
vector< vector<Road> >G(110);

int minLen;//存储目前找过的最佳的路径长度
int totalLen;//已经探索的路径已经走了多长
int totalCost;//长在走的路已经花了多少钱
int visited[110];//标志数组,表示一个城市是否已经走过 

void dfs(int s){
    if(s==N){
        minLen=min(minLen,totalLen);
        return;
    }
    for(int i=0;i<G[s].size();++i){
        Road r=G[s][i];
        if(totalCost+r.t>K)
            continue;
        if(!visited[r.d]){
            if(totalLen+r.L>=minLen){//最优性剪枝: 
                continue;//(1)如果当前已经找到的最优路径长度为L,那么再继续搜索的过程中,总长度已经大于等于L的走法,就可以直接放弃,不用坚持到底 
            } /很强的剪枝,效果拔群 
            totalLen+=r.L;
            totalCost+=r.t;
            visited[r.d]=1;
            dfs(r.d);
            visited[r.d]=0;
            totalLen-=r.L;
            totalCost-=r.t;
        }
    }
}


int main(){
    cin>>K>>N>>R;
    for(int i=0;i<R;i++){
        int s;
        Road r;
        cin>>s>>r.d>>r.L>>r.t;//起点s,终点d,边的长的L,边的过路费t
        if(s!=r.d){
            G[s].push_back(r);
        } 
    }
    //初始化 
    memset(visited,0,sizeof(visited));
    totalLen=0;
    minLen=1<<30;
    totalCost=0;
    visited[1]=1;
    dfs(1);
    if(minLen<(1<<30)){
        cout<<minLen<<endl;
    }else 
        cout<<"-1"<<endl;
    return 0;
} //可惜还是超时 
*/ 



 //POJ1724
//ROADS 深度优先 
#include<iostream>
#include<cstring>
#include<vector>
using namespace std;
int K,N,R;//N个城市 
struct Road{
    int d,L,t;
}; 
//用邻接表存放整条路的信息
vector< vector<Road> >G(110);
int minL[110][10010];///////////////////////////////////
int minLen;//存储目前找过的最佳的路径长度
int totalLen;//已经探索的路径已经走了多长
int totalCost;//长在走的路已经花了多少钱
int visited[110];//标志数组,表示一个城市是否已经走过 

//用mid[k][m]表示:走到城市k时总过路费为m的条件下,最优路径的长度。若在后续的搜索中,在此走到k时,如果总路费恰好为m,且此时的路径长度已经超过mid[k][m],则不必再走下去了。 

void dfs(int s){
    if(s==N){
        minLen=min(minLen,totalLen);
        return;
    }
    for(int i=0;i<G[s].size();++i){
        Road r=G[s][i];
        if(totalCost+r.t>K)
            continue;
        if(!visited[r.d]){
            if(totalLen+r.L>=minLen){
                continue;
            }

            /////////////////////////////////////////////////////////////可行性剪枝: 
            if(totalLen+r.L>=minL[r.d][totalCost+r.t])///////////////////啥都不说了: 
                continue;/////////////////////////////////////////////////加速超快!! 
            minL[r.d][totalCost+r.t]=totalLen+r.L;////////////////////////


            totalLen+=r.L;
            totalCost+=r.t;
            visited[r.d]=1;
            dfs(r.d);
            visited[r.d]=0;
            totalLen-=r.L;
            totalCost-=r.t;
        }
    }
}


int main(){
    cin>>K>>N>>R;
    for(int i=0;i<R;i++){
        int s;
        Road r;
        cin>>s>>r.d>>r.L>>r.t;//起点s,终点d,边的长的L,边的过路费t
        if(s!=r.d){
            G[s].push_back(r);
        } 
    }
    //初始化 
    memset(visited,0,sizeof(visited));
    totalLen=0;
    minLen=1<<30;
    totalCost=0;
    visited[1]=1;//////////////////////////////////
    for(int i=0;i<110;i++){/////////////////////////
        for(int j=0;j<10010;j++){/////////////////
            minL[i][j]=1<<30;///////////////////////
        }//////////////////////////////////////////
    }////////////////////////////////////////////////
    dfs(1);
    if(minLen<(1<<30)){
        cout<<minLen<<endl;
    }else 
        cout<<"-1"<<endl;
    return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
在信号处理领域,DOA(Direction of Arrival)估计是一项关键技术,主要用于确定多个信号源到达接收阵列的方向。本文将详细探讨三种ESPRIT(Estimation of Signal Parameters via Rotational Invariance Techniques)算法在DOA估计中的实现,以及它们在MATLAB环境中的具体应用。 ESPRIT算法是由Paul Kailath等人于1986年提出的,其核心思想是利用阵列数据的旋转不变性来估计信号源的角度。这种算法相比传统的 MUSIC(Multiple Signal Classification)算法具有较低的计算复杂度,且无需进行特征值分解,因此在实际应用中颇具优势。 1. 普通ESPRIT算法 普通ESPRIT算法分为两个主要步骤:构造等效旋转不变系统和估计角度。通过空间平移(如延时)构建两个子阵列,使得它们之间的关系具有旋转不变性。然后,通过对子阵列数据进行最小二乘拟合,可以得到信号源的角频率估计,进一步转换为DOA估计。 2. 常规ESPRIT算法实现 在描述中提到的`common_esprit_method1.m`和`common_esprit_method2.m`是两种不同的普通ESPRIT算法实现。它们可能在实现细节上略有差异,比如选择子阵列的方式、参数估计的策略等。MATLAB代码通常会包含预处理步骤(如数据归一化)、子阵列构造、旋转不变性矩阵的建立、最小二乘估计等部分。通过运行这两个文件,可以比较它们在估计精度和计算效率上的异同。 3. TLS_ESPRIT算法 TLS(Total Least Squares)ESPRIT是对普通ESPRIT的优化,它考虑了数据噪声的影响,提高了估计的稳健性。在TLS_ESPRIT算法中,不假设数据噪声是高斯白噪声,而是采用总最小二乘准则来拟合数据。这使得算法在噪声环境下表现更优。`TLS_esprit.m`文件应该包含了TLS_ESPRIT算法的完整实现,包括TLS估计的步骤和旋转不变性矩阵的改进处理。 在实际应用中,选择合适的ESPRIT变体取决于系统条件,例如噪声水平、信号质量以及计算资源。通过MATLAB实现,研究者和工程师可以方便地比较不同算法的效果,并根据需要进行调整和优化。同时,这些代码也为教学和学习DOA估计提供了一个直观的平台,有助于深入理解ESPRIT算法的工作原理。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值