POJ1458 Common Subsequence

题目:

点击这里查看原题
Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, …, xm > another sequence Z = < z1, z2, …, zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, …, ik > of indices of X such that for all j = 1,2,…,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.
Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
Sample Input

abcfbc abfcab
programming contest
abcd mnp
Sample Output

4
2
0
Source

Southeastern Europe 2003

解答:

//POJ1458 
//最长公共子序列
#include<iostream>
#include<cstring>
using namespace std;
char sz1[1000],sz2[1000];
int maxLen[1000][1000];
int main(){
    while(cin>>sz1>>sz2){
        int length1=strlen(sz1);
        int length2=strlen(sz2);
        int nTmp;
        for(int i=0;i<=length1;i++)maxLen[i][0]=0;
        for(int j=0;j<=length2;j++)maxLen[0][j]=0;
        for(int i=1;i<=length1;i++){
            for(int j=1;j<=length2;j++){
                if(sz1[i-1]==sz2[j-1])maxLen[i][j]=maxLen[i-1][j-1]+1;
                else maxLen[i][j]=max(maxLen[i][j-1],maxLen[i-1][j]);
            }
        }
        cout<<maxLen[length1][length2]<<endl;
    }
    return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值