Monkey and Banana C++

题目:

A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food. 

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. 

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked. 

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks. 
InputThe input file will contain one or more test cases. The first line of each test case contains an integer n, 
representing the number of different blocks in the following data set. The maximum value for n is 30. 
Each of the next n lines contains three integers representing the values xi, yi and zi. 
Input is terminated by a value of zero (0) for n. 
OutputFor each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height". 
Sample Input
1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0
Sample Output
Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

思路:

搭积木,上面的长和宽都要比下面的长和宽大。并且,同一块积木可以随意翻转。

为了方便。我们把每一块积木的x都小于y,这样同一块积木只有三种形态比较了。

再把所有积木按照长和宽的大小从小到大排序。

dp的转移方程为:dp[i]=max(dp[i],dp[j]+s[i].z)。

代码:

#include<bits/stdc++.h>
using namespace std;
struct st
{
    int x,y,z;
}s[100];
bool cmp(st a,st b)
{
    if(a.x==b.x)return a.y<b.y;
    else return a.x<b.x;
}
bool ccc(int a,int b)
{
    return a>b;
}
int main()
{
    int n;
    int tot=1;
    while(cin>>n)
    {
        if(n==0)break;
        int i,t;
        for(i=0;i<3*n;i=i+3)
        {
            cin>>s[i].x>>s[i].y>>s[i].z;
            if(s[i].x>s[i].y)t=s[i].x,s[i].x=s[i].y,s[i].y=t;
            s[i+1].x=s[i].y;
            s[i+1].y=s[i].z;
            s[i+1].z=s[i].x;
            if(s[i+1].x>s[i+1].y)t=s[i+1].x,s[i+1].x=s[i+1].y,s[i+1].y=t;
            s[i+2].x=s[i].z;
            s[i+2].y=s[i].x;
            s[i+2].z=s[i].y;
            if(s[i+2].x>s[i+2].y)t=s[i+2].x,s[i+2].x=s[i+2].y,s[i+2].y=t;
        }
        sort(s,s+3*n,cmp);
        int dp[100];
        memset(dp,0,sizeof(dp));
        for(i=0;i<3*n;i++)
        {
            dp[i]=s[i].z;
            for(int j=0;j<i;j++)
            {
                if(s[j].x<s[i].x&&s[j].y<s[i].y)
                {
                    dp[i]=max(dp[i],dp[j]+s[i].z);
                }
            }
        }
        sort(dp,dp+3*n,ccc);
        printf("Case %d: maximum height = %d\n",tot,dp[0]);
        tot++;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值