POJ 3126 Prime Path(BFS)

8 篇文章 0 订阅

原题

Prime Path

Time Limit: 1000MS Memory Limit: 65536KB 64bit IO Format: %I64d & %I64u

Description

The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices.
— It is a matter of security to change such things every now and then, to keep the enemy in the dark.
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know!
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door.
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime!
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds.
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime.

Now, the minister of finance, who had been eavesdropping, intervened.
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound.
— Hmm, in that case I need a computer program to minimize the cost. You don't know some very cheap software gurus, do you?
— In fact, I do. You see, there is this programming contest going on... Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above.
1033
1733
3733
3739
3779
8779
8179
The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.

Input

One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).

Output

One line for each case, either with a number stating the minimal cost or containing the word Impossible.

Sample Input

3
1033 8179
1373 8017
1033 1033

Sample Output

6
7

0

题意

从一个素数变化为另一个素数,只能以这样的方式变化:
1.一次之改变某一位上的数字
2.改变之后的数字也必须是素数
求这种改变的次数,若无法达到要求,则输出“Impossible”

涉及知识及算法

素数筛选 BFS深度搜索

代码

#include <iostream>
#include <queue>
#include <cstring>
#include <cstdio>
using namespace std;
int p[10000];             //素数集合
int b[10000];             //标记是否访问过
bool pb[10000];           //记录递归深度
int n2;
queue<int> q;
void GetPrime()
{
    memset(p,0,sizeof(p));
    for(int i=2;i<5000;i++)
    {
        for(int j=2;i*j<10000;j++)
        {
            //cout<<i<<"*"<<j<<"="<<i*j<<"是合数"<<endl;
            p[i*j]=1;                 //标记为合数
        }
    }
}

void BFS(int a)
{
    if(a==n2||q.empty()) return;
    q.pop();
    for(int i=0;i<10;i++)
    {
        if(p[a-a%10+i]==0&&pb[a-a%10+i]==0)
        {
            q.push(a-a%10+i);
            pb[a-a%10+i]=1;
            b[a-a%10+i]=b[a]+1;
        }
        if(p[a-a/10%10*10+i*10]==0&&pb[a-a/10%10*10+i*10]==0)
        {
            q.push(a-a/10%10*10+i*10);
            pb[a-a/10%10*10+i*10]=1;
            b[a-a/10%10*10+i*10]=b[a]+1;
        }
        if(p[a-a/100%10*100+i*100]==0&&pb[a-a/100%10*100+i*100]==0)
        {
            q.push(a-a/100%10*100+i*100);
            pb[a-a/100%10*100+i*100]=1;
            b[a-a/100%10*100+i*100]=b[a]+1;
        }
        if(i>0&&p[a-a/1000%10*1000+i*1000]==0&&pb[a-a/1000%10*1000+i*1000]==0)
        {
            q.push(a-a/1000%10*1000+i*1000);
            pb[a-a/1000%10*1000+i*1000]=1;
            b[a-a/1000%10*1000+i*1000]=b[a]+1;
        }
    }
    BFS(q.front());
}

int main()
{
    //freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);
    int kase,n1;
    cin >>kase;
    GetPrime();
    while(kase--)
    {
        memset(pb,0,sizeof(pb));
        memset(b,0,sizeof(b));
        cin>>n1>>n2;
        q.push(n1);
        pb[n1]=1;
        BFS(n1);
        if(b[n2]||n1==n2)cout<<b[n2]<<endl;
        else cout<<"Impossible"<<endl;
        while(!q.empty())
        {
            q.pop();
        }
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值