HDU 6029 个人分析

Graph Theory

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1220    Accepted Submission(s): 553


Problem Description
Little Q loves playing with different kinds of graphs very much. One day he thought about an interesting category of graphs called ``Cool Graph'', which are generated in the following way:
Let the set of vertices be {1, 2, 3, ...,  n}. You have to consider every vertice from left to right (i.e. from vertice 2 to  n). At vertice  i, you must make one of the following two decisions:
(1) Add edges between this vertex and all the previous vertices (i.e. from vertex 1 to  i1).
(2) Not add any edge between this vertex and any of the previous vertices.
In the mathematical discipline of graph theory, a matching in a graph is a set of edges without common vertices. A perfect matching is a matching that each vertice is covered by an edge in the set.
Now Little Q is interested in checking whether a ''Cool Graph'' has perfect matching. Please write a program to help him.
 

Input
The first line of the input contains an integer  T(1T50), denoting the number of test cases.
In each test case, there is an integer  n(2n100000) in the first line, denoting the number of vertices of the graph.
The following line contains  n1 integers  a2,a3,...,an(1ai2), denoting the decision on each vertice.
 

Output
For each test case, output a string in the first line. If the graph has perfect matching, output ''Yes'', otherwise output ''No''.
 

Sample Input
 
 
3212241 1 2
 

Sample Output
 
 
YesNoNo
 

Source
 

Recommend
jiangzijing2015

这道题首先因为个人英语水平有限,多次读题没有明白题目样例,以为进行1操作,是要和前面所有的边进行连线,倘若这样想的话,显然只有2个点1条边的情况符合,因为后面只要出现了1操作,就会出现那个点被多条边覆盖。

但是我们想错了,题目说的并不是这样,进行1操作,可以在前面出现的点里添加一条边(可以不添加),显然,前面如果没有出现2,那么1则和2没有什么区别。同时因为题目要求找的是可能出现的完美匹配,因此,1操作变成了,和前面出现操作2的点连边。题目豁然开朗,以下贴上代码。

#include <iostream>
#include <cstdio>
#include <string.h>
#include <math.h>
using namespace std;

int main(){
    int t, n, cnt, x;
    scanf("%d", &t);
    while(t--){
        scanf("%d", &n);
        cnt = 1;
        for(int i = 1; i < n; i++){
            scanf("%d", &x);
            if(cnt == 0)
                cnt++;
            else{
                if(x == 1)
                    cnt--;
                else
                    cnt++;
            }
        }
        if(cnt != 0)
            puts("No");
        else
            puts("Yes");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值