(HDU 6029 女生专场)Graph Theory 思维题

41 篇文章 0 订阅
14 篇文章 0 订阅

Graph Theory
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 346 Accepted Submission(s): 167

Problem Description
Little Q loves playing with different kinds of graphs very much. One day he thought about an interesting category of graphs called “Cool Graph”, which are generated in the following way:
Let the set of vertices be {1, 2, 3, …, n}. You have to consider every vertice from left to right (i.e. from vertice 2 to n). At vertice i, you must make one of the following two decisions:
(1) Add edges between this vertex and all the previous vertices (i.e. from vertex 1 to i−1).
(2) Not add any edge between this vertex and any of the previous vertices.
In the mathematical discipline of graph theory, a matching in a graph is a set of edges without common vertices. A perfect matching is a matching that each vertice is covered by an edge in the set.
Now Little Q is interested in checking whether a ”Cool Graph” has perfect matching. Please write a program to help him.

Input
The first line of the input contains an integer T(1≤T≤50), denoting the number of test cases.
In each test case, there is an integer n(2≤n≤100000) in the first line, denoting the number of vertices of the graph.
The following line contains n−1 integers a2,a3,…,an(1≤ai≤2), denoting the decision on each vertice.

Output
For each test case, output a string in the first line. If the graph has perfect matching, output ”Yes”, otherwise output ”No”.

Sample Input
3
2
1
2
2
4
1 1 2

Sample Output
Yes
No
No

Source
2017中国大学生程序设计竞赛 - 女生专场

题意:
给你一个有n个节点的图,编号为1,2,..,n。图的边的信息有两种情况:
若节点i的信息是1:表示i和1~i-1的所有的节点都有一条边
若节点i的信息是2:表示i和1~i-1的所有的节点都没有
一个匹配:在一个图的边的集合中没有相同的节点
一个完美匹配:所有的节点都在这个集合中
现在问你,这个图是否是完美匹配的

分析:
由于一个节点,要么和前的节点都有边,要么都没有,所以对于所有后面为1的节点,表示它可以和前面的任意节点进行匹配,而后面为2的节点,要想完美匹配它一定会和它后面为1的节点进行匹配。
相当于后面为1的节点,给你所有节点一个匹配的机会,而后面为2的节点,要占用一次机会。
所有我们用sum记录机会的次数,当遇到1时sum++遇到2时sum–.只要满足在这个过程中sum>=0 ,并且最后sum >=1 (第一个节点为2)即可。

注意:n为奇数时一定不行

由于我判断n为奇数后就直接出了结果,没有进行读取数据了导致wa了几次。。。

AC代码:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>
using namespace std;

const int maxn = 100010;
int a[maxn];

int main()
{
    int t,n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=1;i<n;i++)
        {
            scanf("%d",&a[i]);
            if(a[i] == 2) a[i] = -1;
        }
        if((n%2) == 1)
        {
            printf("No\n");
            continue;
        }
        int sum = 0;
        int f = 1;
        for(int i=n-1;i>=1;i--)
        {
            sum += a[i];
            if(sum < 0)
            {
                f = 0;
                break;
            }
        }
        if(f == 0 || sum < 1) printf("No\n");
        else printf("Yes\n");
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值