PAT_A1046 1046 Shortest Distance (20 分)

题目

  • The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.
  • Input Specification:
    Each input file contains one test case. For each case, the first line contains an integer N (in [ 3 , 10 ​ 5 ] [3,10 ​^5] [3,105]), followed by N integer distances D 1 , D 2 . . . D ​ N D_1,D_2...D​_N D1,D2...DN , where D ​ i D​_i Di is the distance between the i i i-th and the ( i + 1 i+1 i+1)-st exits, and D N D_N DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M ( ≤ 1 0 4 ≤10^4 104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 1 0 7 10^7 107.
  • Output Specification:
    For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.
  • Sample Input:
    5 1 2 4 14 9
    3
    1 3
    2 5
    4 1
  • Sample Output:
    3
    10
    7
  • 源码参考:
/*
myarr[i]存放从头到i处的距离,myarr[0]存放0;
mydis[i]在开始时存放输入的距离数组,后面用作存放输出的两点间距离;
sum存放距离之和。
*/
#include <cstdio>
#include <iostream>
using namespace std;

const int maxn=100010;
int myarr[maxn],mydis[maxn];
int sum=0;

int main()
{
    int N;
    scanf("%d",&N);
    for(int i=0;i<N;++i)
    {
        scanf("%d",&mydis[i]);
        sum=sum+mydis[i];
        if(i==0)
        {
           myarr[i]=0;
        }
        else
        {
            myarr[i]=myarr[i-1]+mydis[i-1];
        }
    }
    int M;
    scanf("%d",&M);
    int a,b;
    for(int i=0;i<M;++i)
    {
        scanf("%d %d",&a,&b);
        if(a>b)
        {
            mydis[i]=myarr[a-1]-myarr[b-1];
        }
        else
        {
            mydis[i]=myarr[b-1]-myarr[a-1];
        }
        if(mydis[i]>sum-mydis[i])
        {
            mydis[i]=sum-mydis[i];
        }
    }
    for(int i=0;i<M;++i)
    {
        printf("%d\n",mydis[i]);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值