PAT_a1046 Shortest Distance

题目描述

作者: CHEN, Yue
单位: 浙江大学
时间限制: 200 ms
内存限制: 64 MB
代码长度限制: 16 KB

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3,10​5​​]), followed by N integer distances D​1​​ D​2​​ ⋯ D​N​​, where D​i​​ is the distance between the i-th and the (i+1)-st exits, and D​N​​ is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤10​4​​), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10​7​​.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3
10
7

解题思路

参考了胡凡《算法笔记上级训练指南》
此题如果没有经过预处理的话很容易超时,我最开始的代码就是没有经过预处理的

#include <cstdio>
#include <algorithm>

int main()
{
	int N;
	int dist[100010];
	int M, re[100010] = { 0 };
	int total = 0;
	scanf("%d", &N);
	for (int i = 1; i <= N; ++i)
	{
		scanf("%d", &dist[i]);
		total += dist[i];
	}
	scanf("%d", &M);
	for (int i = 0; i < M; ++i)
	{
		int e1, e2;
		//int max;
		scanf("%d %d", &e1, &e2);
		int temp = std::max(e1, e2);
		e1 = std::min(e1, e2);
		e2 = temp;
		for(int j=e1;j!=e2;j++)
		{
			re[i] += dist[j];
		}
		/*问题出在这个循环,在极端情况下,每次查询都要遍历整个数组,有10^5次操作,共有10^4次查询,会超过题目时间限制*/
		if (total - re[i] < re[i])
			re[i] = total - re[i];
	}
	for (int i = 0; i < M; ++i)
	{
		printf("%d\n", re[i]);
	}
	return 0;
}

在这里插入图片描述
参考《算法笔记》,对输入距离进行预处理,利用sum数组,对sum[i]来说,它表示的是1号节点按顺时针方向到达“i号节点顺时针方向的下一个节点”的距离,于是对每一对e1->e2,他们之间的距离就是sum[e2-1]-sum[e1-1]。
具体细节的处理见以下代码

#include <cstdio>
#include <algorithm>
using namespace std;
int main()
{
	int sum[100005] = { 0 }, dis[100005];//sum数组一定要初始化为0
	int re[10000];//用来存放结果数组,因为不能输入一对节点就输出结果
	int total = 0, n, m;
	scanf("%d", &n);
	for (int i = 1; i <= n; ++i)
	{
		scanf("%d", &dis[i]);
		total += dis[i];
		sum[i] = total;//预处理
	}
	scanf("%d", &m);
	for (int i = 0; i < m; ++i)
	{
		int e1, e2;
		scanf("%d %d", &e1, &e2);
		if (e1 > e2)//保证一对中终点大于起点
			swap(e1, e2);
		int temp = sum[e2 - 1] - sum[e1 - 1];
		re[i] = min(total - temp, temp);//因为可以顺时针也可以逆时针,所以要取最小值
		//printf("%d\n", re[i]);
	}
	for (int i = 0; i < m; ++i)
	{
		printf("%d\n", re[i]);
	}
	return 0;
}

需要注意的地方

  1. sum数组元素从1号位开始,且sum数组一定要初始化为0,否则,当一对中有节点为1号节点的时候计算会出错;
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值