数据结构-串-字符串的比较

Description
建立字符串的定长存储结构,输入两个字符串,输出比较结果。
Input

输入两个字符串。

Output
相等输出0,不相等时输出对应位置的字符的ASCII码差值。

说明:输出无换行

Sample Input
ABCDE
ABCC
 
Sample Output
1
#include<stdio.h>
#include<bits/stdc++.h>
#include<iostream>
#define Max_str 255
using namespace std;

typedef struct{//存储结构
    char *ch;
    int length;
}Hstring;

void initString(Hstring &S){//初始化
	S.ch=new char[Max_str];
    S.length=Max_str;
    for(int i=0;i<S.length;i++){
        S.ch[i]='\0';
    }
}
void Strass(Hstring &S,char *chars){//生成字符串
    int i=0;
    char *c;
    for(i=0,c=chars;*c;i++,c++);
    for(int j=0;j<i;j++){
        S.ch[j]=chars[j];
    }
    S.length=i;
}
void Strprint(Hstring S){//输出字符串S
    for(int i=0;i<S.length;i++){
        cout<<S.ch[i];
    }
}
int Strcmp(Hstring S,Hstring T){//比较字符串S、T,并返回对应位置的字符的ASCII码差值
    for(int i=0;i<S.length&&i<T.length;i++){//有返回值
        if(S.ch[i]!=T.ch[i]){
            return S.ch[i]-T.ch[i];
        }
    }
    return 0;
}
int main(){
    Hstring S,T;
    initString(S);
    initString(T);
    char chars[Max_str];
    char chars1[Max_str];
    cin>>chars;
    cin>>chars1;
    Strass(S,chars);
    Strass(T,chars1);
    cout<<Strcmp(S,T);
    return 0;
}

 

  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值